Add Product Still Not Working: Checked Permissions

We have been building and designing our site for weeks with no problems with the “add product” and successfully uploaded test products with no problem. .

Then, All of a sudden the ‘add product’ stopped working. We have tried this as the mega admin and through a vendor account.

THE ISSUE: We are unable to add products. When you go to the Products page and push add product button, then input product information there are two errors… 1) the upload image is not working, we have tried both to upload through the FTP client and manually upload, neither is working and 2) when you put in information and select “create” and/or “create and close” no action is being taken. It will not create the product. It does not give an error. It just simply does nothing. (and yes, all required fields are completed).

Actions we have taken: As suggested on the forum, we have already doublechecked our permissions, and they are all set correctly… please give us a solution/suggestion other than this if you have one!

Background information: We were having trouble with our category images, we had uploaded images but it stopped automatically generating the image to our category page (category trees etc). We decided to delete the block in our grid. When we did this, all the products in our product inventory were deleted suddenly. We did not manually change anything with our products. I am confused why this would occur, as the products should be stand alone… they (the products). We are not sure if this is related to the problem described above, but the day after we did this is when it stopped letting us upload products.

We are waiting on this resolve in order to launch our site. We have submitted a ticket, but that is taking 3 or 4 days and we are trying to get this resolved asap (of course)

Thank you in advance.