500 Internal Server Error...host Says It's My .htaccess File?

I went to load my web site today and got a 500 internal server error. I reported it to my host and they said if they disable my .htaccess file the problem goes away.

I haven't changed anything in the .htaccess file for ages, so I'm not sure why it's suddenly a problem.

I do have an issue with other sites on my VPS where the cPanel AutoSSL is not automatically renewing for some reason, so a bunch of those sites are not accessible currently. My Kingsley Press site has separate SSL certificate from GeoTrust.

Not sure what's going on here but if anyone has any suggestions where to look, I'd sure appreciate it.


homepage working ok for me UK 19:11 gmt

sub pages give 404, do you have rewritebase set ok as

RewriteBase /

or maybe you have changed your seo settings in addons

try and replace config.local.php and .htaccess or compare from a recent backup

DOWNLOAD these ones first though as a precaution

My host has temporarily disabled my .htaccess and put some kind of generic placeholder in its place.

My .htaccess file starts with:

Directory Index index.html index.php

Then goes on to mod_deflate, mod_headers, etc.

I'm not seeing

RewriteBase /

anywhere in my htaccess file

I've noticed .htaccess not getting updated during upgrades. It doesn't change often but there has been changes. Here is the latest version for 4.7.3.

DirectoryIndex index.html index.php

    # Compress HTML, CSS, JavaScript, Text, XML, fonts
    AddOutputFilterByType DEFLATE application/javascript application/x-javascript text/javascript application/json
    AddOutputFilterByType DEFLATE application/x-font application/x-font-opentype application/x-font-otf application/x-font-truetype application/x-font-ttf font/opentype font/otf font/ttf application/x-woff application/x-font-woff
    AddOutputFilterByType DEFLATE text/css text/html text/plain

    # Remove browser bugs (only needed for really old browsers)
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    Header append Vary User-Agent

Header set Access-Control-Allow-Origin "*"

Cache all images for 2 weeks

ExpiresActive on ExpiresDefault "access plus 2 weeks" Header set Cache-Control "max-age=1209600" RewriteEngine on # Please note that RewriteBase setting is obsolete use it only in case you experience some problems with SEO addon. # Some hostings require RewriteBase to be uncommented # Example: # Your store url is http://www.yourcompany.com/store/cart # So "RewriteBase" should be: # RewriteBase /store/cart # RewriteBase /

This setting is commented out because it might cause an error on some servers where MultiViews override is forbidden.

Enabling MultiViews can lead to unexpected results if an URI (for example, an URI of a SEO name)

matches the structure of folders in the root directory of the store.

If you have such URIs, please uncomment the following lines

Options -MultiViews

RewriteRule ^init.php$ - [F,L,NC]

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_URI} ^api/(.)$ [or]
RewriteCond %{REQUEST_URI} .
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .api/(.)$ api.php?_d=$1 [L,QSA]

RewriteCond %{REQUEST_URI} .(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff|yml|xml)$ [NC,or]
RewriteCond %{REQUEST_URI} store_closed.html$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.?)/(.)$ $2 [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L,QSA]

This prevents possible problems when downloading files

php_flag zlib.output_compression Off

Thank you, that's helpful.


Restored my .htaccess file and everything seems OK again. Must have been a temporary glitch...maybe caused by AutoSSL issues.

This problem has re-occurred. My home page loads to a blank screen.

I have replaced my .htaccess file with the one from Tool above, but it makes no difference--home page loads to a blank screen.


Never mind. I figured out the problem. It was the VivaShop theme license addon. Somehow it had toggled itself to "disabled." Their licensing server must have been offline when I was logging in to the backend this morning.

Wasted me a good hour or two. Wish there was some way for them to do their licensing stuff without risking taking people's sites offline.

Additionally, in my urgency to find a fix I bought support credits from CS-Cart for $45. But now I don't need those. Does anyone know if they are refundable?

The way we do it is we set a 5 second timeout on the license request. If it fails to respond in that period of time, we just move on and assume the customer has the proper license. We store the fact that a timeout occured so that other licensed products are not even checked.