Jump to content

 

The Tool

Member Since 30 Mar 2007
Offline Last Active Yesterday, 05:51 PM
*****

#312905 Deafult Shipping For All Locations

Posted by The Tool on 05 March 2019 - 02:48 AM

Sorry, don't know the keyboard mapping for Pounds so you'll have to accept my $$!!! :-)

 

£ - Alt 0163

€ - Alt 0128




#312628 Image Seo Problem

Posted by The Tool on 23 February 2019 - 02:48 PM

It looks like it has something to do with the gallery?  Products with a single image appears to be working fine.

 

Also ecom's addon appears to be working fine unless you have manually entered the alt text.




#311986 Configure Htaccess File On Linux Centos

Posted by The Tool on 07 February 2019 - 05:19 PM

Administration->Logs->Select gear icon->PHP information




#310535 Update Entire Sites Image From Absolute To Relative?

Posted by The Tool on 28 December 2018 - 05:50 PM

If you don't have that many pages then why not edit the pages manually instead of messing with the database directly?
 
Page descriptions are located in table cscart_page_descriptions.




#308961 Paypal Ipn And Google Recaptcha (Addon From Ecom Labs) Stoped Working

Posted by The Tool on 14 November 2018 - 01:03 PM

Note that E.Qi.Librium is using 4.3.9 Flow.

 

There are several differences in the file but it appears this is what CSC added to E.Qi.Librium's file /app/Tygh/http.php:

 

Find

    /**
     * Parse response contents to split headers
     * @param  string $content response contents
     * @return string contents without headers
     */
    private static function _parseContent($content)
    {
        while (strpos(ltrim($content), 'HTTP/1') === 0) {
            list(self::$_headers, $content) = preg_split("/(\r?\n){2}/", $content, 2);
        }

        return $content;
    }

Replace:

    /**
     * Parse response contents to split headers
     * @param  string $content response contents
     * @return string contents without headers
     */
    private static function _parseContent($content)
    {
        while (strpos(ltrim($content), 'HTTP/1') === 0) {
            list(self::$_headers, $content) = preg_split("/(\r?\n){2}/", $content, 2);
        }
        
        while (strpos(ltrim($content), 'HTTP/2') === 0) {
            list(self::$_headers, $content) = preg_split("/(\r?\n){2}/", $content, 2);
        }

        return $content;
    }



#304800 Orders List Issue With Responsive Admin

Posted by The Tool on 01 August 2018 - 11:23 PM

https://forum.cs-car...l-period-serch/




#304507 Update Entire Sites Image From Absolute To Relative?

Posted by The Tool on 25 July 2018 - 11:35 PM

Where exactly is the Image source input on the category page?  Description?
 
If they are in the description then run this query...

UPDATE cscart_category_descriptions SET description = REPLACE(description, 'http://www.mysite.com', '');

Backup the table before running the query.




#304491 Where Can I Downlod The Version 4.7.4 Of Multivendor ?

Posted by The Tool on 25 July 2018 - 05:59 PM

Contact CSC help desk.




#303388 Site Displaying Pages Extremely Slow

Posted by The Tool on 28 June 2018 - 05:22 PM

Home page is huge at over 4MB.  You have images being scaled down to less than a 1/4 of their original size.  I would start with images before messing with server config.




#301775 Bug On 4.7.4: Blocks.post.php Adding Certain Configuration Breaks The Block C...

Posted by The Tool on 18 May 2018 - 01:09 PM

You can report bugs here https://forum.cs-cart.com/tracker/




#301698 Gdpr Policy In The Eu

Posted by The Tool on 16 May 2018 - 10:11 PM

All I can say is I sure am glad I am on the other side of the pond.




#301279 Cs-Cart Cannot Handle High Traffic

Posted by The Tool on 07 May 2018 - 09:18 PM

Could also be some sort of attack by anonymous bots.




#299929 Php Warning: Strpos():

Posted by The Tool on 09 April 2018 - 08:19 PM

Suggest you look at line 61 on your site of the social_buttons/func.php file.


I posted that piece/line of code above and you have what I have.
 

Suggest you submit a report to bugtracker with this info.


I did a month ago and it's been under review for as long. That's why I am picking your brain. Do you reckon we'll get compensated for fixing it? LMAO

What exactly does ". " do? It's the only thing I see different in your code and the original.


#299745 Features

Posted by The Tool on 05 April 2018 - 09:31 AM

Is your "Brands" feature id "1"?  If not then add the appropriate feature id number.

 

I use this on a daily basis so I know it works.  You just need to make sure everything is exact.

 

Edit:  Also the field name is supposed to be "Features" and not "Feature" and make sure the feature name is "Brands" and not "Brand".

 

If all else fails, do like ecom said and manually add the brand to one product then export it to see the exact format.




#299570 Issues After Upgrade To 4.7.2

Posted by The Tool on 02 April 2018 - 08:26 PM

Update:  I couldn't save the file in cPanel's editor because it kept saving as gb18030 and changing the code.  I ended up having to edit the file via ftp.