Jump to content

 

roshanruzaik

Member Since 16 Jun 2019
Offline Last Active Apr 01 2020 09:57 AM
-----

Posts I've Made

In Topic: Double_Selectboxes.tpl Not Working Inside Models.

29 March 2020 - 08:09 AM

Thanks cscartrocks for your reply

 

Actually there is no any JS errors in the browser console. 


In Topic: Double_Selectboxes.tpl Not Working Inside Models.

28 March 2020 - 07:54 AM

Hi,

 

Has anyone experienced the same ? or am I trying to deal with the flow incorrectly?

 

Please advice

 

Regards,


In Topic: Is It Possible To Have Multiple Stores With Each Assigned Its Own Dedicated W...

18 January 2020 - 07:12 AM

Thank you 'The Tool' and 'Flow' for your suggestions, 

 

Really appreciate your replies.

 

We will also explore some more ideas.

 

Thank you, 


In Topic: How To Import And Use An Existing Class From A Different Addon In My Addon?

20 October 2019 - 10:44 AM

 

I would do something like:

if( !class_exists('Class1') )
  include(Registry::get('config.dir.addons'')."/myaddon/Class1.php");

 

Hi tbirnseth,

 

This works for me. 

 

Thanks for the tip.


In Topic: How To Import And Use An Existing Class From A Different Addon In My Addon?

19 October 2019 - 06:42 AM

You can certainly use an existing class if the addon it is contained within is active.

 

Regarding yor 500 error...  What are the paths to your 2 classes relative to your app/addons/myaddon1 directory?

Hi,

 

Pardon for my late reply,

 

Here are the class paths,

 

I want to access Class1 methods from MyApi class.

 

\app\addons\my_api\Tygh\Api\Entities\MyApi.php

\app\Addons\myaddon1\Class1.php

 

I also would like to know how to capture exact errors while working with API classes.

 

Regards,