Jump to content

 

arteeni

Member Since 07 Aug 2015
Offline Last Active Oct 17 2017 08:51 PM
-----

Topics I've Started

Hiding The Seo Product Tab For Vendors

09 January 2017 - 06:21 PM

Hi everyone,

 

We've decided to handle all product SEO as our vendors don't have a clue what that is. So, I'm trying to hide the "SEO" tab in the product admin (i.e. products.update and products.add) for vendors, but keep visible for admin. I managed to hide all of the content of the tab (by modifying /design/backend/templates/views/products/update.tpl), but not hide the tab itself.

 

Can someone please point me in the right direction?

 

Thanks,

Jason


Nofollow Tag Being Stripped From Page Content

29 December 2016 - 07:28 PM

Hi everyone,

 

From time to time I want to selectively add a rel="nofollow" tag to a link on a content page. But, when I save, it is stripped out (i.e. deleted). Is that intentional? If so, why and how can I get around that?

 

Thanks,

Jason


Gift Certificate Email Template

17 November 2016 - 04:12 AM

Hi everyone,

 

I'm running into an issue and hoping someone can help me. I have modified the gift certificate email template with a new design, but when the email is generated none of the CSS formatting is being used. I'm not used to including CSS code directly like this, but I did it the same way as what was in the original template, so it seems like it should work.

 

What I see (see attachment)

 

And, here is my template code:

<html>
<head>
<link rel="stylesheet" type="text/css" href="http://fonts.googleapis.com/css?family=Marck+Script">
</head>

{literal}
<style type="text/css">
.thelabels {
   font-family: Marck Script;
   font-size: 20px;
}
.theheader {
   font-family: Marck Script;
   font-size: 25px;
}
.contentcells {
   border-bottom: 1px solid black;
   width: 300px;
}
table {
   padding: 15px;
   background-color: #f7f7f7;
   border-style: solid;
   border-radius: 20px;
   border-width: 2px;
}
p,span2 {
   border-bottom: 1px solid black;
   line-height: 29px;
   width: 300px;
}
p>span2 {
   padding-bottom: 5px;
   width: 300px;
}
</style>
{/literal}

<body>
{include file="common/scripts.tpl"}
<table border="0" cellpadding="5" cellspacing="2"
 width="600">
  <tbody>
    <tr>
      <td colspan="3" rowspan="1">
	<img src="{$logos.gift_cert.image.image_path}" width="{$logos.gift_cert.image.image_x}" height="{$logos.gift_cert.image.image_y}" border="0">
	{* width: 171px; height: 62px; *}
      </td>
      <td rowspan="7" colspan="1" style="width: 75px;"></td>
    </tr>
    <tr>
      <td style="width: 75px;" colspan="1" rowspan="6"></td>
      <td colspan="2" rowspan="1" height="50"
 valign="top">
      <div class="theheader" style="text-align: center;">You
have received a Gift Certificate!
      </div>
      </td>
    </tr>
    <tr>
      <td style="width: 150px;">
      <div class="thelabels">{__("gift_cert_from")}:</div>
      </td>
      <td>
      <div class="contentcells">{$gift_cert_data.sender}</div>
      </td>
    </tr>
    <tr>
      <td style="width: 150px;">
      <div class="thelabels">Amount:</div>
      </td>
      <td>
      <div class="contentcells">{include file="common/price.tpl" value=$gift_cert_data.amount}</div>
      </td>
    </tr>
    <tr>
      <td style="width: 150px;">
      <div class="thelabels">Code:</div>
      </td>
      <td>
      <div class="contentcells">{$gift_cert_data.gift_cert_code}</div>
      </td>
    </tr>

{if $gift_cert_data.message}
    <tr>
      <td style="width: 150px;">
      <div class="thelabels">Message:</div>
      </td>
      <td>
      <p><span2>{$gift_cert_data.message nofilter}</span2></p>
      </td>
    </tr>
{/if}

    <tr>
      <td height="40">
      <div class="thelabels">Redeemable at:</div>
      </td>
      <td><a href="http://www.arteeni.com/">http://www.arteeni.com</a></td>
    </tr>
  </tbody>
</table>
</body>
</html>

Any idea what could be causing this?

 

Thanks,

Jason


Changing The Email "from" Name

29 August 2016 - 06:31 PM

Hey guys,

 

I'm running MV and want to change it so that all emails related to orders show our store name (Arteeni) as the From name, not the name of the Vendor.

 

While playing around with this, I was able to accomplish this for the Shipment notification by deleting

'company_id' => $order_info['company_id'],

from the "fn_update_shipment" function in fn.cart.php.

 

So, a few questions:

     1.) Is doing it that way fine, or could it cause issues?

     2.) If it could cause issues, is there a better way to do it?

     3.) Lastly, is it possible to make this change (whether my approach or an alternative) "globally", or would

          it have to be done to each mailer call?

 

Thanks,

Jason


Issue When Entering A Comma In The Price Field

09 June 2016 - 08:53 PM

We stumbled on an issue where if we enter a comma in a product's price field (ex: "1,000") and then save, when the page refreshes, it contains a value of "1". However, it works fine if "1000" is entered.

 

Is there anything that can be done to handle an entry that contains a comma? My initial thought would be to look for a comma in those fields and strip it out before the value is actually recorded. Thoughts?

 

Thanks for your help,

Jason