Jump to content

 

Galactica

Member Since 20 Jun 2013
Offline Last Active Dec 03 2013 09:41 PM
-----

#169330 4.0.2 Post Template Hook Did Not Override the Default Styles. Fixed .... O RLY?

Posted by Galactica on 07 October 2013 - 07:20 PM

Change log for 4.0.2 states:

Addons: CSS styles connected via a post template hook did not override the default styles. Fixed.

Posted Image

Nope, just added the my changes css post template hook and tried switching the body background color and it is overwritten by the default styles still.

Firebug shows that my custom css is being added to the standalone stylesheet, but unfortunately it isn't being placed at the very bottom, so some default cart styles are overriding mine still.

Brand new install of 4.0.2 with my changes add on.


#166226 Hook Path Question

Posted by Galactica on 02 August 2013 - 02:32 PM

Have you tried:-

design/frontend/skins/1/basic/templates/addons/my_changes/hooks/checkout/discount_coupons.pre.tpl
Where '1' is active skin ID.

Are your other working hook pre/post/override in the same setup, ie:-
themes/basic/templates/addons/my_changes/hooks/index/blah.post.tpl



Thank you for all of your suggestions so far, I really appreciate it!

I saw the first path in another forum post when I was trying to dig up some answers, but I thought that was only for cs-cart versions below 4? As the new version doesn't have the directories:

design/frontend/skins

cs-cart 4 has:

design/themes/[theme_name]

I did however try and add the theme files into a "1" directory and unfortunately it didn't work.

To answer your 2nd question all of my other hooks are set up the same way and work as they should (thankfully):

themes/basic/templates/addons/my_changes/hooks/index/styles.post.tpl

themes/basic/templates/addons/my_changes/hooks/buttons/add_to_cart.override.tpl

Could this be another addon/template overriding my changes that I can't see? I wish there were better docs for design/development, makes tracking these things down pretty damn tough...


#164816 Turn Off Cache Completely In v4 While Editing?

Posted by Galactica on 03 July 2013 - 04:56 PM

Solved: Need to set the "Rebuild Cache Automatically" toggle to ON in Design/Template Editor. I completely missed that setting... So much easier to edit now.

Keep in mind you will want to turn this off when not editing your site so it runs faster...