Jump to content

 

grafis

Member Since 12 Jan 2011
Offline Last Active Mar 27 2021 03:10 PM
-----

Posts I've Made

In Topic: Warnings At Every Login - The Product Xxx Has Options Or Option Variants That...

02 April 2019 - 12:34 AM

Have a check that you dont have any products in your basket in the "storefront"

 

Thanks - and yes confirmed there's nothing in the Cart in the Storefront.

Per your note above I wasn't aware you create and order via the backend! 


In Topic: Warnings At Every Login - The Product Xxx Has Options Or Option Variants That...

24 March 2019 - 07:32 PM

This error may happen only when product in cart has disabled/removed option.

 

Unfortunately this notification cannot be removed without code modification.

 

 

Thanks but when I login as admin the items listed in my errors are not disabled and have not been removed and most do not even have options.  Logged in as a user 2 of the 3 errors are products with options and one is not, all are enabled and active. 


In Topic: Warnings At Every Login - The Product Xxx Has Options Or Option Variants That...

24 March 2019 - 01:10 PM

 

I found the second line from above in two places, setting it to Zero under the Enable Dev mode heading Worked, not even sure what that heading means! The other location is under //Developer Configuration File and has both the lines above, I turn that one to my IP when testing. So off for now but not sure what I've done! (enable Dev mode - IF Product Status is not empty, ummm....???). Thanks, I think!

// Enable DEV mode if Product status is not empty (like Beta1, dev, etc.)
if (PRODUCT_STATUS != '' && !defined('DEVELOPMENT')) {
    ini_set('display_errors', '0');

 

The errors are back... I've disabled everything error/dev related I can find. 

Happens for customer non admin login and for admin login. Stumped...


In Topic: Warnings At Every Login - The Product Xxx Has Options Or Option Variants That...

23 March 2019 - 03:21 PM

 

You need to set in your config.local.php 

error_reporting(E_ALL & ~E_NOTICE);
ini_set('display_errors', 0);

I found the second line from above in two places, setting it to Zero under the Enable Dev mode heading Worked, not even sure what that heading means! The other location is under //Developer Configuration File and has both the lines above, I turn that one to my IP when testing. So off for now but not sure what I've done! (enable Dev mode - IF Product Status is not empty, ummm....???). Thanks, I think!

// Enable DEV mode if Product status is not empty (like Beta1, dev, etc.)
if (PRODUCT_STATUS != '' && !defined('DEVELOPMENT')) {
    ini_set('display_errors', '0');

In Topic: Warnings At Every Login - The Product Xxx Has Options Or Option Variants That...

23 March 2019 - 02:57 PM

I get this now and then, usually after i create and order in the back end, and add an option or remove an option from the product I have added to the quote. Try and clear your cache or rename the cache folder

 

John

 

or 

https://forum.cs-car...on-for-product/

 

Thanks - tried deleting all cache from /Var - no change.