Jump to content

 

remoteone

Member Since 06 Oct 2009
Offline Last Active Jul 08 2019 03:18 PM
-----

Posts I've Made

In Topic: Meet Cs-Cart & Multi-Vendor 4.10.1 With New Checkout And Product Variations

01 July 2019 - 12:26 PM

Yes, uservoice was of limited success. Many csc users posted similar requests for the same function. So the votes were distributed over many posts for the same thing. There was no merging of topics/votes into one. Some users required "critical, deal breaker" functions, but these just werent important to others, thus got low votes. Understandably, I think CSC just treated uservoice as a guideline of sorts.

 

 

In Topic: Seo Not Working On Sitemap And 301S

01 July 2019 - 12:08 PM

Perhaps the issue is that our store,  onwireless.com.au is an addon domain to the Primary server domain of onwireless.net
Thus https://onwireless.com.au is located at https://onwireless.net/store.
So may be the installation does not really fit either scenario detained in the documentation.
 
Anyhoo.. the workaround has solved the issue, I need to spend time working on the new software platform now.
Thanks for the help. Much appreciated.
 


0 Links

In Topic: Seo Not Working On Sitemap And 301S

01 July 2019 - 11:32 AM

Thanks The Tool.  My files were correct.
Re "secure path in config.local.php", https is working but I'll investigate further.
Cheers

In Topic: Seo Not Working On Sitemap And 301S

29 June 2019 - 01:35 PM

Update:  also replaced the three occurrences of 'config.http_location' with 'config.https_location' in /addons/google_sitemap/func.php

All urls in sitemap.xml are now https.

Its a workaround that no doubt stuff things if SSL is disabled. It would be better to have a proper fix.


In Topic: Seo Not Working On Sitemap And 301S

29 June 2019 - 12:57 PM

I actually have no expertise in php but I just replaced 3 instances of 'http' with 'https' . in /addons/google_sitemap/func.php

Ie

	if (count($languages) == 1) {
		$links[] = fn_url($link, 'C', 'https', '&', CART_LANGUAGE);
	} else {
		foreach ($languages as $lang_code => $lang) {
			$links[] = fn_url($link . '&sl=' . $lang_code, 'C', 'https', '&', $lang_code);
		}
	}

and

			if ($seo_enabled) {
				$name = $location . '/sitemap' . $i . '.xml';
			} else {
				$name = fn_url('xmlsitemap.view?page=' . $i, 'C', 'https', '&');
			}

It partially works,  but the main url is still generated as http,  so my guess is this would stuff things if the SSL was off.

Temporary partial workaround at best.
 

Is it possible for someone to post the correct v2.1.4 files for me to check  against my files?

need v 2.1.4 original files as follows.:

  addons/form_builder/controllers/customer/pages.post.php

  core/fn.control.php