Jump to content

 

aircomms

Member Since 30 Jun 2008
Offline Last Active Apr 13 2018 09:33 AM
-----

#224084 Upgrade 4.3.3 Failed

Posted by aircomms on 23 July 2015 - 11:05 AM

Finally I resolved the issues of the upgrades and why the last 2 failed so badly, thanks eComslabs for your help; with it I would not have looked further.

The server was running a PHP handler "dso" this allowed the files to run as nobody and caused issues to in the upgrades as it did not have permissions to run correctly. This seems to only effect upgrade to 4.3.2 & 4.3.3. I changed to PHP handler "suPHP" and reset all permissions and ownership across the server.

The following are run on a cPanel based Cent-OS platform -

Change all permissions for folders from 777 to 755
The following command will change the folders inside public_html for all accounts to 755, it doesn’t just list the ones needing changed:
find /home/*/public_html -type d -exec chmod 755 {} \;
Change all permissions for files from 666 to 644
The following command will change the files inside public_html for all accounts to 644, it doesn’t just list the ones needing changed:
find /home/*/public_html -type f -exec chmod 644 {} \;

Fix ownership to public_html contents to user:user (rather than user:nobody), but keep top level of public_html as user:nobody
for i in `ls /var/cpanel/users/`; do chown -R $i:$i /home/$i/public_html ; done
for i in `ls /var/cpanel/users/`; do chown $i:nobody /home/$i/public_html ; done

The first command recursively chowns all files and folders inside public_html to the users found in /var/cpanel/users folder. The second command puts the top-level of public_html as user:nobody as it needs to remain that setting.

Remove any php_value and php_flag entries in .htaccess files as they will produce an Internal Server Error if in an account’s .htaccess file.
find /home -type f -name ‘.htaccess’ -exec grep -Hrn ‘php_value’ ‘{}’ \;
find /home -type f -name ‘.htaccess’ -exec grep -Hrn ‘php_flag’ ‘{}’ \;

I ran the upgrade to 4.3.3 and it failed until I reset the following to these values in the config.local.php

// Default permissions for newly created files and directories
define('DEFAULT_FILE_PERMISSIONS', 0644);
define('DEFAULT_DIR_PERMISSIONS', 0755);

Re-running the upgrade script worked with this in place.

On a final note I would like to say CS-Cart thank you for taking 15 credits, resolving nothing and wasting 2 weeks of my time waiting for you. You explainations are poor at the best of times and seem to lack the basic understanding of what we are saying. I can not see myself paying of support again with you as I would rather pay someone else like ecomslabs who have been more helpful in a shorter time than you have been. It is a shame cs-cart support is so poor as it ruins a such a good product.


#182704 Upgrade To Universal Analytics (Google Analytics)

Posted by aircomms on 30 April 2014 - 01:56 PM

In version 4.1.x edit -

design/themes/xxxxxxx/templates/addons/google_analytics/hooks/index/footer.post.tpl

and replace the line

ga.src = ("https:" == document.location.protocol ? "https://ssl" : "http://www") + ".google-analytics.com/ga.js";

with

ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';