Jump to content

 

CutRiteFX

Member Since 02 Jun 2008
Offline Last Active Jul 28 2019 01:37 AM
-----

Topics I've Started

New Install Asks For Php Extensions: Curl Sockets

22 July 2019 - 07:15 PM

I currently have 4.10.3 installed and have had cscart for years. I have noticed a few issues with the database. So I wanted to install a fresh copy. Put a new copy on the server and started installation and this is what I get.

 

I have verified that these are installed by calling my hosting company.

 

I even added added the extensions to php.ini and still no luck. Don't understand because I already have had cscart installed for years on same server.

 

Checking requirements

×Server configuration doesn't meet the requirements. Please contact your server administrator or hosting provider to address the issues described below
RequiredNetwork requests support

Required for proper functioning of several payment gateways (such as PayPal, Authorize Net, etc.) and real-time shipping services (FedEx, UPS, DHL), for sending e-mails via SMTP, and for upgrading your store.

Install all these PHP extensions: curl sockets

 


Upgrade 4.9.3.sp1 - 4.10.1 Failed Migration

11 June 2019 - 09:00 PM

I have no mods to the store other than a theme. Has anyone else had this issue.
I have cleared cache before the upgrade and still get this.
 
Upgrade process of your store has failed
Please restore the pre-upgrade backup manually or via a link sent to your email address, then contact our technical support.
 
 
Tech details: Couldn't complete migration 20181227063741_addons_store_locator_modify_store_locations_table.php. Reason: Unknown column 'pickup_surcharge' in 'cscart_store_locations'.
 
Completed migrations: 18 out of 43.