Jump to content

Issue information

  • #003827

  • Closed


Issue Confirmations

  • Yes (1)No (0)
Photo

installer - 500 Internal server error

Posted by Guest_Zoltan_* on 24 April 2013 - 08:05 PM

Hi,

I have tried to install the 4.0.1 Beta, but unfortunatelly I did not get far. During the install process when I fill out the DB connection data and click the Install button, the "progress" message flashes out and disappear immediatly and nothing happens. In the firebug I can see that the ajax query got the 500 Internal server error response. I quess that dispatch setup.next_step tries to makes an illegal redirect or something.

I got the same if I rename the .htaccess file or not. There is already a production cs-cart running on the server, so I think the apache settings are fine.

Here is the request info from firebug:
(sorry about the censore stars)


Access-Control-Allow-Cred... true
Access-Control-Allow-Orig... http://dev2.***.hu
Cache-Control no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Connection close
Content-Length 0
Content-Type text/html; charset=utf-8
Date Wed, 24 Apr 2013 19:16:01 GMT
Expires Thu, 19 Nov 1981 08:52:00 GMT
Last-Modified Wed, 24 Apr 2013 19:16:01 GMT
Pragma no-cache
Server Apache/2.2.24 (FreeBSD) PHP/5.3.24 with Suhosin-Patch mod_ssl/2.2.24 OpenSSL/0.9.8x DAV/2
X-Frame-Options sameorigin
X-Powered-By PHP/5.3.24
Request Headersview source
Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Encoding gzip, deflate
Accept-Language en-US,en;q=0.5
Connection keep-alive
Cookie __utma=270184371.292025040.1364664028.1366741046.1366826743.31; __utmz=270184371.1364664028.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); sess_id=6fdi90lgsoh9q66hap2kookak6; __utmc=270184371; PHPSESSID=pa13l8qane88gq660elr94hk15
Host dev2.***.hu
Referer http://dev2.***.hu/install/index.php
User-Agent Mozilla/5.0 (Windows NT 6.2; rv:20.0) Gecko/20100101 Firefox/20.0
Request Headers From Upload Stream
Content-Length 895
Content-Type application/x-www-form-urlencoded

1 request
0 B
81ms
-----------------------------------------

POST index.php

500 Internal Server Error

dev2.***.hu

0 B

*.52.166.75:80


81ms
HeadersPostHTMLCookies
Parametersapplication/x-www-form-urlencoded
cart_settings[demo_catalo... Y
cart_settings[email] zoli@***.hu
cart_settings[feedback_au... Y
cart_settings[languages][... en
cart_settings[languages][... de
cart_settings[languages][... es
cart_settings[main_langua... en
cart_settings[password] ***
cart_settings[secret_key] Kvk95AgTrw
cart_settings[skin_name] basic
database_settings[host] localhost_db
database_settings[name] ***hu_dev2
database_settings[notify] 1
database_settings[passwor... ***
database_settings[table_p... ***hudev2_
database_settings[user] ***hu_dev2
dispatch setup.next_step
dispatch[setup.next_step] Install
is_ajax 3
server_settings[correct_p... 0
server_settings[http_host... dev2.***.hu
server_settings[http_path...
server_settings[https_hos... dev2.***.hu
server_settings[https_pat...

1 request

0 B

81ms

Looks like something wrong with the index.php for me but both versions are giving me the same error -

[Thu Apr 25 11:52:36 2013] [error] [client 192.168.0.1] Premature end of script headers: index.php


Dear speedy, can you please contact us at www.cs-cart.com/helpdesk and provide us with FTP access to your server. We will investigate the issue on your server.
Please add the "for Ilya Makarov" note in the subject of a ticket.

Thank you.


Hi,

I can confirm this 500 error as well. It's quite strange because at first time I could install the package without any problem. I deleted the database and all FTP files and tried to reinstall. But the installer didn't start and I the instal.php returned with 500 internal server error. Deleted cache, started new session but no avail.
I use PHP version 5.3.17


While installing the software when the following page is being loaded there is no error. But If I press I reload it returns with 500 Error. It's so strange. Do you have any idea why?
http://domain.com/in...tch=setup&sl=en


Ok I found my solution. It was a permission problem. The install folder doesn't work for me with permission 777. If I use 755 it works well.


changed status to: Closed