Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Please Help! Rate Topic   - - - - -

 
  • ionutemt
  • Advanced Member
  • Trial users
  • Join Date: 07-Oct 16
  • 94 posts

Posted 10 May 2022 - 04:55 PM #1

Hello

Please help me with a big problem.
 
I installed the latest version of cscart, everything went very well but I can't do the product feeds with suppliers.
 
Unable to import urls.
 
If I try to import the same file on another cscart site ... it works.
 
Even our programmer doesn't know where to go.
 
I have attached a video for details.
 
Thank you!


 
  • ionutemt
  • Advanced Member
  • Trial users
  • Join Date: 07-Oct 16
  • 94 posts

Posted 10 May 2022 - 04:57 PM #2

 

Hello

Please help me with a big problem.
 
I installed the latest version of cscart, everything went very well but I can't do the product feeds with suppliers.
 
Unable to import urls.
 
If I try to import the same file on another cscart site ... it works.
 
Even our programmer doesn't know where to go.
 
I have attached a video for details.
 
Thank you!

 



 
  • ionutemt
  • Advanced Member
  • Trial users
  • Join Date: 07-Oct 16
  • 94 posts

Posted 10 May 2022 - 04:59 PM #3

 

 

Hello

Please help me with a big problem.
 
I installed the latest version of cscart, everything went very well but I can't do the product feeds with suppliers.
 
Unable to import urls.
 
If I try to import the same file on another cscart site ... it works.
 
Even our programmer doesn't know where to go.
 
I have attached a video for details.
 
Thank you!

 

 



 
  • asereje
  • Newbie
  • Trial users
  • Join Date: 13-Jun 18
  • 4 posts

Posted 11 May 2022 - 08:26 AM #4

I did some troubleshooting and it seems to be a bug in the advanced_import addon.

The checking

if (!in_array(strtolower($ext), $this->allowed_ext)) {

in

app\addons\advanced_import\Tygh\Addons\AdvancedImport\FileManager.php
is not working ($this->allowed_ext array values are now also arrays).
Try to replace with:

if (!array_key_exists(strtolower($ext), $this->allowed_ext)) {

 

The developer has upgraded the addon - so, there is a new array structure for allowed_ext in
    app\addons\advanced_import\schemas\advanced_import\allowed_extensions.php

but the upgrade is not complete - and introduces this bug.

 



 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3943 posts

Posted 08 June 2022 - 01:30 PM #5

Are you still facing this issue? If yes, please let me know additional details, like how it could be reproduced and which version of CS-Cart/Multi-Vendor you are using at the moment.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • seniorx
  • Member
  • Members
  • Join Date: 03-Mar 14
  • 22 posts

Posted 08 June 2022 - 03:52 PM #6

Salut colega,
Ce probleme asa dificile ai intampinat?