Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Php 7.4 Rate Topic   - - - - -

 
  • myshop
  • Member
  • Members
  • Join Date: 08-Aug 12
  • 25 posts

Posted 17 September 2020 - 11:36 AM #1

I see in the release notes of the latest version I notice there have been improvements to PHP 7.4 compatability, however there has been no documentation update that I can find to give us specifics?

 

All I can find is this: https://docs.cs-cart...quirements.html and it doesn't mention PHP 7.4.

 

Can someone confirm or otherwise the latest CS-Carts PHP compatibility?



 
  • harmsmitsdev
  • Advanced Member
  • Members
  • Join Date: 22-Feb 20
  • 53 posts

Posted 17 September 2020 - 11:44 AM #2

I see in the release notes of the latest version I notice there have been improvements to PHP 7.4 compatability, however there has been no documentation update that I can find to give us specifics?

 

All I can find is this: https://docs.cs-cart...quirements.html and it doesn't mention PHP 7.4.

 

Can someone confirm or otherwise the latest CS-Carts PHP compatibility?

Currently its not compatible, there are however indications that it will be in 4.12;



 
  • cigarhut
  • Newbie
  • Trial users
  • Join Date: 16-Aug 19
  • 3 posts

Posted 23 September 2020 - 10:22 PM #3

in the install guide docs for CS-Cart System Requitrements I see that the following PHP commands should be enabled: system     exec     shell_exec     passthru

These are by default disabled on cpanel servers running PHP 7.3 (ea-php73) PHP-FPM
 

disable_functions	exec,passthru,shell_exec,system

as these open up serious security holes, how critical are they to run CS Cart 4.11.5?
do we really need to essentially hack the default config of cpanel and open up our server to vulnerabilities to run this?

see here for the reasons why they are explicitly blocked
https://alionder.net...-php-functions/

see here for how to enable them

https://serverok.in/...-php-fpm-cpanel