Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

How To Enable Ssl Https On My Eshop Rate Topic   - - - - -

 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 14 September 2020 - 07:32 AM #1

Dear Sirs,

I am running cs-cart 3.0.3 in a rather old Ubuntu server 12.04 with Apache2 version: 2.2.22  PHP Version: 5.3.10-1ubuntu3.26

 

I want to activate full https working for my eshop and I can not find the way to do.

Please note that I have correct and valid SSL certificate, also the apache is configured correct (I think), ex. when I point to cs-cart admin page I have full SSL working (https://)

Please help me how can do it.

 

Thanks and Best Regards,

Mike Kranidis



 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 15 September 2020 - 07:38 PM #2

Please, someone to help me?
Thanks

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 21077 posts

Posted 16 September 2020 - 05:16 AM #3

Please find article for 3.x version here

 

http://kb.cs-cart.co...nnection-failed


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 16 September 2020 - 06:05 AM #4

Dear Sirs,

I followed your advice and I checked my eshop founder that the test page (https://www.biofarm....ore_closed.html) is working fine. 

Further more, still the access of my shop is done without ssl even if I specify https in the URL.

Any advice on how to activate full https support?

Many thanks.

 

Best Regards,

Mike Kranidis



 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 18 September 2020 - 03:30 PM #5

Anyone to help me please?

Thanks

Dear Sirs,

I followed your advice and I checked my eshop founder that the test page (https://www.biofarm....ore_closed.html) is working fine. 

Further more, still the access of my shop is done without ssl even if I specify https in the URL.

Any advice on how to activate full https support?

Many thanks.

 

Best Regards,

Mike Kranidis



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11815 posts

Posted 18 September 2020 - 07:36 PM #6

Verify that you have your Administration/Security settings set to the appropriate values for your version.

Verify that your config.local.php has your site name in the https_host config parameter.

Clear your cache manually by deleting this folder and it's contents var/cache

 

Your SSL seems to be installed correctly given https://www.biofarm.gr/changelog.txt loads correctly and is SSL.  Hence I'd assume is either your Security Settings or that your cache is not clearing properly..

 

If those all check out, then contact your hosting and ask them about it.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 19 September 2020 - 07:09 AM #7

Dear Sir,

Thanks for your answer.

Although even the administration control panel is working fine with SSL (https) I can't make it work with the site...

Probably I am having something wrong in my setup...

Is there any chance to have your support for this issue? We can negotiate for a fair price for this I think.

Please tell me what do you need (I have full SSH root access to my server) and what the charge will be.

 

Best Regards,

Mike Kranidis

Verify that you have your Administration/Security settings set to the appropriate values for your version.

Verify that your config.local.php has your site name in the https_host config parameter.

Clear your cache manually by deleting this folder and it's contents var/cache

 

Your SSL seems to be installed correctly given https://www.biofarm.gr/changelog.txt loads correctly and is SSL.  Hence I'd assume is either your Security Settings or that your cache is not clearing properly..

 

If those all check out, then contact your hosting and ask them about it.



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11815 posts

Posted 19 September 2020 - 07:03 PM #8

Have you verified your Administration/Security settings?

What version of cs-cart are you running?

Have you manually cleared the cache as suggested?

 

If you want to discuss support, please click the 'get-a-quote' link in my signature and we can discuss what it will cost to have hands-on support for your issue.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 19 September 2020 - 07:21 PM #9

Dear Sir,

I have not verify Administration/Security settings, because I am not sure how...

I am running 3.0.3  version, you can see it running the command: https://www.biofarm.gr/changelog.txt

I have manually clear the cache following your suggestion above, nothing changed, still not getting SSL / https

 

Please see my above replies and then, I can click your support link...

Thanks

 

Have you verified your Administration/Security settings?

What version of cs-cart are you running?

Have you manually cleared the cache as suggested?

 

If you want to discuss support, please click the 'get-a-quote' link in my signature and we can discuss what it will cost to have hands-on support for your issue.



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11815 posts

Posted 19 September 2020 - 07:51 PM #10

Go to Settings menu.

Select Security Settings

Be sure the top box is selected for Full Site


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 19 September 2020 - 08:47 PM #11

Dear Sir,

I did what you suggested me but not getting lock at my browser (Chrome)...

Just to make sure, I enabled this setting, is it the correct?

Thanks a lot.

Link: https://photos.app.g...YXHGQSsEaerRKPA

 

Go to Settings menu.

Select Security Settings

Be sure the top box is selected for Full Site



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11815 posts

Posted 20 September 2020 - 09:29 PM #12

Suggest you "check" the top 4 items.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 21077 posts

Posted 21 September 2020 - 05:07 AM #13

Your store-front uses https

 

https://prnt.sc/ukv2iu

 

But it still has http:// links. E.g.

 

https://prnt.sc/ukv2v9

 

It causes the issue. Review content of your store and change all links to https


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • mikekgr
  • Newbie
  • Trial users
  • Join Date: 14-Sep 20
  • 8 posts

Posted 21 September 2020 - 06:00 AM #14

Dear Sirs,

Now it is more clear what I have to do and thanks for your help.

 

Best Regards,

Mike Kranidis

Your store-front uses https

 

https://prnt.sc/ukv2iu

 

But it still has http:// links. E.g.

 

https://prnt.sc/ukv2v9

 

It causes the issue. Review content of your store and change all links to https



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11815 posts

Posted 21 September 2020 - 06:20 PM #15

Rather than using src="https://example.com/image.png"use src="//example.com/image.png" instead.  It will use whatever the current protocol is that's in the current state.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.