Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Credit Card Processing Issues Rate Topic   - - - - -

 
  • AVO-Ken
  • Senior Member
  • Members
  • Join Date: 05-Nov 11
  • 153 posts

Posted 04 September 2020 - 09:33 PM #1

Wondering if anybody has had to tackle an issue with processing credit cards. We have used both PayFlow Pro and Authorize.net

 

App. 4 months ago we had issues with PayFlow pro and the we switched to Authorize.net which is now having issues.

 

We have exhausted our efforts with CSC Support, Hosting Provider Support and Payment gateway support. They point their fingers somewhere else.

 

The problem is: The CC transaction leaves our website fine and goes to the payment gateway fine. They process the transaction but we do not receive a response from the payment gateway. Again, this problem exists with 2 gateways.

 

So the CC is approved but the customer sees failed message because there is no response from the payment gateway. We log into the gateway and the payment info is valid and good but that is not what we see in admin or on the storefront. Failed messages come back and I am told that is because a response is not received. So the customer runs their CC many times which is a huge issue.

 

For now we have CC processing disabled and are using the ugly and out dated PayPal Express Checkout method which in itself is not professional and not helping sales.

 

Any insight appreciated. Now thinking it must be something specific to my server. Something is not running correctly.

 

Thanks

Ken



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 20936 posts

Posted 07 September 2020 - 06:14 AM #2

Payment gateway providers usually have logs of requests with transaction status. Did they try to check these logs?


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • AVO-Ken
  • Senior Member
  • Members
  • Join Date: 05-Nov 11
  • 153 posts

Posted 08 September 2020 - 02:10 PM #3

Authorize.net says they do not log the API calls.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 20936 posts

Posted 09 September 2020 - 05:10 AM #4

What did CS-Cart support say?


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • AVO-Ken
  • Senior Member
  • Members
  • Join Date: 05-Nov 11
  • 153 posts

Posted 11 September 2020 - 03:45 PM #5

ecom - Thanks for the responses and sorry for the delays.

 

CSC Support has made a fair effort to  look at the problem and they do not know the root cause. All they can tell me is that the HTTP request is being sent out properly and we do see that through our CC processing gateway login but CSC is not receiving a response so it shows a declined message.

 

We have used 2 different CC processors and both worked fine initially and then stopped working some time later which is very odd.

 

I have since (finally) moved one of my dev sites to a new server with a new host and it works fine over there so I can only assume the issue is either with my server or with my host. The site does pass PCI scanning with my current settings so I know at least nothing is grossly wrong.

 

The current host is GoDaddy and I moved my dev site to Hostwinds. I know everyone pretty much hates Godaddy. I was not aware of their issues when I signed with them many years ago but have experienced some less than desireable issues that are specific to GD. I was already planning on moving when my 1 year plan expired this year ragardless of this issue. I won't go into their issues at this time.

 

Anyhow, I am hoping to move my live site this weekend to hostwinds.

 

BTW: My initial impression of hostwinds is not very good but I expect it to get better.

I am using unmanaged VPS. I have created 2 separate unmanaged VPS accounts with them and both of them had issues getting turned on and both were generating errors that only the more experienced users could fix. They offer absolutely 0 support for unmanaged servers and would not fix the issues. Fortunately, they allow for easy upgrade and downgrade for managed/unmanaged. The cost difference is almost double but it is just for one month. I pay more for support with CSC. Anyhow, they do have 24/7 tech support so the issues did not take long to get fixed. It is just BS that they provision a new VPS with issues. Gonna stick with them for now as the site does work properly and a bit faster.

 

Thanks

Ken