Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Database error: 1044 : Access denied for user: Rate Topic   - - - - -

 
  • hoodbizz
  • Junior Member
  • Members
  • Join Date: 28-Jun 06
  • 8 posts

Posted 28 June 2006 - 08:21 PM #1

Hi!

I am getting the error message below when I run the installation wizzard on my server. I have created a cscart database as it seems to request, but it does not solve the problem. I have not figured out yet the way around it.
Is anyone familiar with the process to overcome that problem? Can you help me with that process information please?

Thank you.

--------------------------------------------------------------------------
Database error: 1044 : Access denied for user: 'hoodbizz@localhost' to database 'cscart'
Invalid query: CREATE DATABASE IF NOT EXISTS cscart


Backtrace: File: /home/hoodbizz/public_html/cs-cart/install.php
Line: 31
Function: include
File: /home/hoodbizz/public_html/cs-cart/core/install.php
Line: 267
Function: db_create_db
File: /home/hoodbizz/public_html/cs-cart/core/db_mysql.php
Line: 64
Function: db_query
File: /home/hoodbizz/public_html/cs-cart/core/db_mysql.php
Line: 89
Function: db_error

 
  • susio1
  • Junior Member
  • Members
  • Join Date: 17-May 06
  • 7 posts

Posted 28 June 2006 - 09:20 PM #2

--------------------------------------------------------------------------
Database error: 1044 : Access denied for user: 'hoodbizz@localhost' to database 'cscart'
Invalid query: CREATE DATABASE IF NOT EXISTS cscart


Using your control panel of your web host, double check the database name, user name, and database password are the same you are inputing into CS-Cart during the install process.

 
  • hoodbizz
  • Junior Member
  • Members
  • Join Date: 28-Jun 06
  • 8 posts

Posted 29 June 2006 - 02:46 AM #3

Index of /
Name Last modified Size Description--------------------------------------------------------------------------------
cs-cart/ 27-Jun-2006 08:14 -
--------------------------------------------------------------------------------
Apache Server at hoodbizz.com Port 80

 
  • hoodbizz
  • Junior Member
  • Members
  • Join Date: 28-Jun 06
  • 8 posts

Posted 29 June 2006 - 03:00 AM #4

Thank you Susio1!

The initial problem is overcomed, but I still encounter some installation problems. Instead of pointing directly to the homepage, I get the following page when I type my site address in the browser:
_________________________________________________________________
Index of /

Name Last modified Size Description----------------------
cs-cart/ 27-Jun-2006 08:14 -
--------------------------------------------------------------------------------
Apache Server at hoodbizz.com Port 80
_________________________________________________________________

Then when I click on (cs-cart/), it takes me to the mainpage.

1)- How do I fix that please?
2)- How do I choose a different skin than the current one at this point? (I want to use the (brickwork yellow and green) instead.
3)- The products images don't appear right, what could be the problem and how to approach that?

Thank you very much...

 
  • Gregh
  • Member
  • Members
  • Join Date: 14-Jan 06
  • 47 posts

Posted 29 June 2006 - 07:05 AM #5

im not sure if this is what you mean mate.
In the config file of your cart

(// Host and directory where cs-cart is installed on usual server
$cscart_http_host = 'www.yourstite.com';
$cscart_http_dir = 'cscart/')
In the config file of your cart. If yourcart is at www.yoursite.com/cscart/

If at www.yoursite.com just delete cscart/ from it
Then it would look like
((// Host and directory where cs-cart is installed on usual server
$cscart_http_host = 'www.yourstite.com';
$cscart_http_dir = '')
Hope it helps
Greg
1.3.5 sp4

 
  • susio1
  • Junior Member
  • Members
  • Join Date: 17-May 06
  • 7 posts

Posted 30 June 2006 - 04:25 AM #6

1)- How do I fix that please?


I agree with Gregh's advise. It also might of been typo during initial setup.(sometimes using an extra character such as "\" or "http://yoursite.com" instead of "http://www.yoursite.com" can mess up the install)

2)- How do I choose a different skin than the current one at this point? (I want to use the (brickwork yellow and green) instead.


Skin changes are done thru your CS-cart admin panel. menu on right side, Look and Feel ->> Skin selector.

3)- The products images don't appear right, what could be the problem and how to approach that?


Not sure but have suggestions: Double check for any typo's in config file. Also could be due to a .htaccess file problem or folder permission problem