Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Shipping Method Working At Cart But Not At Checkout Rate Topic   - - - - -

 
  • geokir
  • Member
  • Trial users
  • Join Date: 06-Dec 12
  • 27 posts

Posted 20 June 2020 - 12:20 PM #1

Hello, I got an issue with my CS-Cart eshop.

The basic shipping method I got is working at the cart page but it is not working at the checkout. Explaining further:

 

1. when the client is at the cart he can choose his location and the shipping methods and costs are working as needed

2. when he continues to the checkout and he changes his address town (or when he has not choose any shipping method at the cart page) the shipping method is not working

 

It like the CMS cant read the location change at the checkout page. I think its a bug or a conflict or something similar. It happened after adding some other plugins but disabling them does help any more.

 

Any clue?

 

Regards

Giorgos



 
  • geokir
  • Member
  • Trial users
  • Join Date: 06-Dec 12
  • 27 posts

Posted 23 June 2020 - 08:28 PM #2

Any help guys? How could I debug the site and find this issue? Can I disable the shipping in checkout maybe and make it obligatory to choose from the cart?



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11667 posts

Posted 24 June 2020 - 05:47 PM #3

If there was a change in address, it could be that the address is not supported by the Destinations specified in the shipping method Rates.  If the address (state, country, postal) are the same then it would require investigation on your site.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • geokir
  • Member
  • Trial users
  • Join Date: 06-Dec 12
  • 27 posts

Posted 25 June 2020 - 05:57 AM #4

Hello and thanks for the answer, my destinations and rates are correct. I can see those working fine in the cart page.

Its like the obligatory state field change does not triggers as it shoulds.



 
  • daimion
  • Advanced Member
  • Members
  • Join Date: 19-Mar 15
  • 72 posts

Posted 03 July 2020 - 02:36 AM #5

I've had this problem and raised it too: https://forum.cs-car...t-not-updating/

 

You are right that it doesn't seem to detect a change, and update. I've found that deleting and re-entering the fields, recalculates the rates - but it is quite unprofessional to have to describe this to customers. And this is only if they ask - never know how many just thinks shipping is not available and leave.



 
  • geokir
  • Member
  • Trial users
  • Join Date: 06-Dec 12
  • 27 posts

Posted 03 July 2020 - 06:13 AM #6

Hi Daimion and thanks for the answer. So you still got this problem right?

 

I thought that maybe re-entering states etc will help. I mean build the entire shipping procedutre at the back-end from the scratch. You tried it?



 
  • Zahhar
  • Junior Member
  • Members
  • Join Date: 01-Nov 08
  • 33 posts

Posted 02 August 2020 - 12:16 PM #7

Bug reported, please upvote:

https://forum.cs-car...ountry-changes/


Boutique digital agency, marketing automation: bergdigital.ch