Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

error message when purchasing a downloaded product Rate Topic   - - - - -

 
  • lazerage
  • Junior Member
  • Members
  • Join Date: 17-Oct 07
  • 3 posts

Posted 18 February 2008 - 06:32 AM #1

Greetings,

I'm having a strange error when a customer purchases an online product. the order processes fine, but when they go to the download screen, they get the error:

>>Error
Access Denied

you can see the link here:
http://www.squallpre...EN&currency=usd

I also noticed, that the cart drops to http:// versus https:// when it was processing the credit cards...

any thoughts on the matter would be much appreicated....
cheers,

 
  • ThomH
  • Senior Member
  • Members
  • Join Date: 20-Nov 07
  • 1456 posts

Posted 18 February 2008 - 03:10 PM #2

No error. works fine for me

WebGraphiq offers a wide range of professionally developed, ready to use CS-Cart add-ons to provide additional functionality and boost your sales. The oldest active CS-Cart add-on development team. -- Since 2006 --


CS-CART ADD-ONS | FREE QUOTE | CS-CART DEVELOPMENT | @webgraphiq


 
  • eye2i images
  • Junior Member
  • Members
  • Join Date: 20-Sep 07
  • 5 posts

Posted 07 August 2009 - 09:19 PM #3

Hi

I am having the same problem with the error message, did you ever managed to sort this out and if so I would appreciate your help if you could tell me what you did to cure this problems

Many Thanks

Laura

:)

 
  • ogia
  • Senior Member
  • Members
  • Join Date: 09-Aug 09
  • 503 posts

Posted 08 September 2009 - 10:45 PM #4

I'm having the same problem, but it only occurs with a few files here and there. For instance, I just had a customer place and order with 3 items. 2 downloaded fine and the 3rd file resulted in the error. It was set up correctly in the admin and pointed to the right file. Another time, the customer had 20+ files and one of them resulted in the access denied error.

I'm scratching my head here.
CS-Cart 2.1.3 | Selling downloads
I recommend Newsletter Integration with Mailchimp

 
  • ogia
  • Senior Member
  • Members
  • Join Date: 09-Aug 09
  • 503 posts

Posted 08 September 2009 - 10:47 PM #5

Additional info... I am logged in as the customer right now... I uploaded the file again and left the old one (the one that resulted in the error) intact. When I tried downloading again, both files worked without error. :confused:
CS-Cart 2.1.3 | Selling downloads
I recommend Newsletter Integration with Mailchimp

 
  • ogia
  • Senior Member
  • Members
  • Join Date: 09-Aug 09
  • 503 posts

Posted 08 September 2009 - 10:53 PM #6

...and I deleted one of them and now the other one doesn't work. I have tried re-uploading the file about 10x now and get the access denied error every time. The file itself is fine, so I'm not sure why access is denied.
CS-Cart 2.1.3 | Selling downloads
I recommend Newsletter Integration with Mailchimp

 
  • rockonup
  • Junior Member
  • Members
  • Join Date: 17-Nov 07
  • 26 posts

Posted 19 May 2010 - 07:55 AM #7

When I check out as a customer the file name and size is there under downloads when I click on the name of the file to download i get a "403 Access denied you don't have permission to access the page". I even gave permissions to the files. Im uploading from a CSV sheet too also is there anyway to change the Activation Mode to Immediately in the CSV or a setting somewhere, so I dont have to go through each product changing that as well? I can click the file in the Admin error of product and it downloads fine and works from. Why doesn't this work through the customer side.

 
  • Wildlyfe
  • Newbie
  • Members
  • Join Date: 19-Mar 18
  • 6 posts

Posted 01 August 2018 - 01:15 AM #8

I am having this exact problem.  I can't figure out why some products are giving me the error and not all.  Same setting used on all the products.   Order shows as processed, but access is denied from the download link in the customer's email, and shows as not available or expired in the download list.  I haven't seen anyone post a fix for this.