Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Mod Security Error Upgrading From 4.8.1 To 4.9.2 Rate Topic   - - - - -

 
  • carterj
  • Junior Member
  • Members
  • Join Date: 11-May 09
  • 103 posts

Posted 02 January 2020 - 07:49 PM #1

Upgrading from 4.8.1 to 4.9.2 and now I have 2 issues:

 

1.  Mod_Security Error: An appropriate representation of the requested resource could not be found on this server. This happens when I try saving under settings:company  OR Store:<website>. 

I also notice that "vendor:" does not appear in front of my domain like my other site does, which upgraded fine to 4.11.2.

 

2. Doman is not rewriting to add the "www" in front of the domain name anymore.

 

I have restored the updates from 4.8.1 three times, still get the same condition.  Compared files, reset permissions, no 3rd party add-ons, cleared cache.  I'm thinking maybe a corrupt file or from a previous install I never realized until now.

 

Does anyone have any ideas I'm missing?

 


Using CS-CART 4.11.x


 
  • soft-solid
  • Junior Member
  • Authorized Reseller
  • Join Date: 19-Apr 10
  • 997 posts

Posted 02 January 2020 - 07:59 PM #2

Hello

 

Did you try disable mod_security on server ?

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • carterj
  • Junior Member
  • Members
  • Join Date: 11-May 09
  • 103 posts

Posted 02 January 2020 - 08:13 PM #3

Yup, did that too, but I think my isp overides my setting since I still get the message.


Using CS-CART 4.11.x


 
  • soft-solid
  • Junior Member
  • Authorized Reseller
  • Join Date: 19-Apr 10
  • 997 posts

Posted 02 January 2020 - 08:20 PM #4

Hello

 

mod_security has many rules in its settings. Probably a rule causes problems. An analysis of the web server logs would definitely be helpful. Ask your ISP to disable mod_security for testing. The second issue is access to the rules management capabilities of this module (mod_security). You must get them.

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • carterj
  • Junior Member
  • Members
  • Join Date: 11-May 09
  • 103 posts

Posted 02 January 2020 - 08:26 PM #5

Something I just noticed with url rewriting:

 

On my site that is working, after I click save on the company info it comes back with: dispatch=companies.update&company_id=1&selected_section=detailed

 

On the site having issues: after I click on save, the URL redirects to the <admin>.php?

 

I can't find any difference in the .htaccess or config files with the other site that is working.  Could there be a rewrite reference in another file or the DB?


Using CS-CART 4.11.x


 
  • soft-solid
  • Junior Member
  • Authorized Reseller
  • Join Date: 19-Apr 10
  • 997 posts

Posted 02 January 2020 - 10:38 PM #6

Hello

 

Mod_security probably truncates the request. I am not a specialist but I once had a similar case. Editing mod_security rules helped.

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19982 posts

Posted 05 January 2020 - 07:06 AM #7

Please check the mod_security section here

 

https://docs.cs-cart...quirements.html


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • carterj
  • Junior Member
  • Members
  • Join Date: 11-May 09
  • 103 posts

Posted 20 January 2020 - 05:27 PM #8

Thanks for the link.  This is good reference.  Now it's up to convincing the Host Provider to modify for my instance. :( 


Using CS-CART 4.11.x