Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Permissions Issue. Mve Upgrade 4.11.1 To 4.11.1 Sp1 Rate Topic   - - - - -

 
  • gavintme
  • Newbie
  • Trial users
  • Join Date: 05-Aug 19
  • 2 posts

Posted 30 November 2019 - 08:45 PM #1

Hi Everyone,

 

My first post on the forum, although I have been reading through many posts for a while now as I was setting up my recent MVE site.

 

Anyway I have searched quite a bit and haven't been able to find a solution for this issue below...

 

Trying to upgrade Multi Vendor from 4.11.1 to 4.11.1 SP1.

 

I download the install as normal, performed the test upgrade to check PHP script timeout and this completes successfully.

When I click on Install I get the following Permissions Error...

 

Permissions issue  

These files require write permissions set (manually or automatically via FTP)

File js/tygh/core.js config.php app/lib/vendor/composer/autoload_static.php app/lib/vendor/composer/autoload_real.php app/lib/vendor/autoload.php app/schemas/security/secure_controllers.php app/schemas/settings/actions.functions.php app/Tygh/Notifications/DataProviders/OrderDataProvider.php app/addons/graphql_api/lib/vendor/composer/autoload_static.php app/addons/graphql_api/lib/vendor/composer/autoload_real.php app/addons/graphql_api/lib/vendor/autoload.php app/addons/discussion/schemas/security/secure_controllers.post.php app/addons/gift_certificates/schemas/security/secure_controllers.post.php app/addons/searchanise/schemas/security/secure_controllers.post.php app/addons/store_locator/func.php app/addons/form_builder/schemas/security/secure_controllers.post.php app/functions/fn.control.php app/functions/fn.init.php /var/www/clients/client1/web1/web/upgrades

When I click on Auto set permissions via FTP, I then enter FTP details and click continue and nothing else happens. The window closes and I am left with the Permissions Error screen again. I need to refresh the page to do anything else.

 

I have also checked every one of the files in the above list manually via FTP and the permissions for every file are 644 (which I assume is correct?)

I am not sure what the last line is (/var/www/clients/client1/web1/web/upgrades)   but it is certainly not a file or path I can find in my installation.

 

Previous upgrades have been successful on this server with no problems. I also manually backed up the site and tried to upgrade while skipping the back up and the same thing happened.

 

I must add.... before installing CSCart I had never worked with any web/server installations etc but I am learning quickly.

 

Any help is much appreciated.

 

Many thanks

Gavin.



 
  • gavintme
  • Newbie
  • Trial users
  • Join Date: 05-Aug 19
  • 2 posts

Posted 02 December 2019 - 09:53 AM #2

EDIT....

 

Just a correction to the original post...

 

I have upgraded a version of MVE on this server previously and it completed without any problem. However since then the server has been configured with full page caching and it is also using Cloudflare. This was all set up for me by the server admin.

So it is possible there may be some conflict there with the upgrade.

 

However...

Everything else on the site operates as normal. Also, if it is a server issue, then where do I start to find the problem?

 

Thanks.



 

Posted Today, 02:36 PM #3

I had a same issue. I've solved that problem.

 

Step 1:

chmod -R 777 js

chmod -R 777 app

 

Step 2:

Upgrade.

 

Step 3:

chmod -R 755 js 

chmod -R 755 app