Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Seo Addon Not Working After Moving. Rate Topic   - - - - -

 
  • druweed
  • Member
  • Trial users
  • Join Date: 09-Oct 17
  • 25 posts

Posted 25 October 2019 - 05:44 AM #1

So i was working on a store on o subdomain and now we went live with the store.

i just moved it from subdomain to domain, same server db etc.

noticed sef urls not working, so i disabled the addon, and tried to activate it again. it's not working, 

checked paths, checked .htacess.. 

on error log PHP Notice: Undefined index: a in /home/abex/public_html/app/addons/seo/func.php on line 1580

 

I'm out of ideas, 



 
  • soft-solid
  • Junior Member
  • Members
  • Join Date: 19-Apr 10
  • 885 posts

Posted 25 October 2019 - 10:04 AM #2

Hello

 

What does it mean that it doesn't work? There are no friendly links. Are there any other symptoms besides this warning?

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19766 posts

Posted 25 October 2019 - 01:28 PM #3

Please make sure that the RewriteBase parameter is correct in the .htaccess file


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • druweed
  • Member
  • Trial users
  • Join Date: 09-Oct 17
  • 25 posts

Posted 27 October 2019 - 10:08 AM #4

i have no friendly urls, the addon itself is disabled and won't start.

i get a message to check server 

so i checked the .htaceess file, even replaced it with original, talked to hosting, mod_rewrite is enabled, 

seo addon just won't start. 



 
  • soft-solid
  • Junior Member
  • Members
  • Join Date: 19-Apr 10
  • 885 posts

Posted 27 October 2019 - 10:22 AM #5

Hello

 

What is the message shown when trying to enable the addon?

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19766 posts

Posted 28 October 2019 - 05:58 AM #6

i have no friendly urls, the addon itself is disabled and won't start.

i get a message to check server 

so i checked the .htaceess file, even replaced it with original, talked to hosting, mod_rewrite is enabled, 

seo addon just won't start. 

 

Try the following solution

 

https://forum.cs-car...rk/#entry256522


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • druweed
  • Member
  • Trial users
  • Join Date: 09-Oct 17
  • 25 posts

Posted 06 November 2019 - 02:07 PM #7

it was a bug in my seo addon, fixed using cs-cart helpdesk.