Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Migration Error While Upgrading 4.3.8 -> 4.3.9 I Rate Topic   - - - - -

 

Posted 02 August 2019 - 08:14 AM #1

i've just attempted to upgrade and while upgrading 4.3.8 -> 4.3.9 
I get the following error, can I proceed with upgrading to later versions as I want to get the store up to the latest release?

ERROR An error has occured during upgrading database structure
(applying migration
20160628085312_core_change_user_sess_prod_order_id_not_null_zero.php).

 

Got a response back from support to say roll back and they would update the database with the missing col.

 

Done that yet still waiting for a response, does anybody have a way of finding out what the issue was and I can update the DB.

 

I know I'm several version behind but I'm trying to catch up, I don't care about the interim release I just want the final release 4.10.x but i'm told i need to upgrade each and every one as there is no release purely to upgrade the DB.

 

thanks 



 
  • soft-solid
  • Junior Member
  • Members
  • Join Date: 19-Apr 10
  • 855 posts

Posted 02 August 2019 - 12:04 PM #2

Hello

 

You need to look at the migration file. If during the upgrade the migration shows an error after correcting the database or migration file, you can load the console level migrations. It is a bit complicated but it can be done.

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 

Posted 02 August 2019 - 01:21 PM #3

Robert, where would i get the migration files, I'm happy to work through these but no idea where to locate them.

 

thomas



 

Posted 07 August 2019 - 12:03 PM #4

CS Support sent me a script to correct this issue.

 

thanks