Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Ssl Rate Topic   - - - - -

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 01 February 2008 - 10:06 AM #21

RESOLVED!!!!!!

Thank you all for the help.

I figured it was me doing something wrong and it was!

I have the public_html protected with a password etc, this is (belt and braces) to protect the site until complete (we were hacked once before) and secure.

When you tick a check box in admin it fails because it gets access denied (even though we logged in) and once I removed the protection it worked first time!!!!

Sorry to have wasted all your time, but it never crossed my mind that this would be an issue.

Thanks again.

BarryH

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • cr0wn3r
  • Junior Member
  • Members
  • Join Date: 18-Nov 07
  • 8 posts

Posted 04 February 2008 - 04:00 PM #22

Thanks for posting the solution barry, because Ive been having exactly the same problem for exactly the same reason... :)

Solved.
Cs-Cart v1.3.5

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 04 February 2008 - 06:33 PM #23

Glad it has helped!!!!!!

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • jeremyw
  • Junior Member
  • Members
  • Join Date: 05-Jun 07
  • 7 posts

Posted 06 February 2008 - 07:27 PM #24

Awesome solution -- banged my head for a couple of days trying to figure out why the SSL wouldn't work and it was simply the password on the site directory. THANK YOU. The odd thing was that my store wouldn't even let me turn on the SSL option, I had to re-enable SSL every time and it wouldn't stick and the cart links weren't going to https at all... now it works fine. I also never thought that would affect the store's operation with SSL, but apparently so.

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 06 February 2008 - 10:27 PM #25

Once enabled you can put password back on web and everything is fine!

BarryH

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • willflint
  • Junior Member
  • Members
  • Join Date: 04-Feb 08
  • 3 posts

Posted 09 February 2008 - 03:45 PM #26

the public_html protected with a password etc


Barry,
I don't understand, is this a folder on your server? I don't have a folder called public_html. My site is hosted by Gisol.com on linux with Hsphere control panel. The site is at the root of a subdomain, which has a domain alias equal to my site. I have never been able to figure out why the checkbox thing doesn't work, so I resorted to editing the database and forcing it to be secure:

UPDATE `cscart`.`cscart_settings` SET `value` = 'Y' WHERE `cscart_settings`.`option_id` =10003 LIMIT 1 ;

UPDATE `cscart`.`cscart_settings` SET `value` = 'Y' WHERE `cscart_settings`.`option_id` =10004 LIMIT 1 ;

UPDATE `cscart`.`cscart_settings` SET `value` = 'Y' WHERE `cscart_settings`.`option_id` =7147 LIMIT 1 ;

Thanks,
Will Flint
CEO
RCIS Designs LLC
http://www.rcisdesigns.com
http://www.askwilliestylez.com
http://www.buymoregadgetz.com (cs-cart)

Hosted by www.gisol.com
Linux - Shared
Shared SSL
CS-Cart 1.3.5 SP1
PHP 4.7
MySQL DB

 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 09 February 2008 - 04:21 PM #27

Hi Will

Yes, this is our root directory. If your coding works for you then go with it. We didn't need to change the code (not my strong point).

Best of luck

Barry

BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User