Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Paypal Payments Stuck On Open Rate Topic   - - - - -

 
  • mrmem
  • Member
  • Members
  • Join Date: 13-Jul 09
  • 94 posts

Posted 10 June 2019 - 12:25 AM #1

I received email that cPanel & WHM version (11.76.0.22) will reach end of life.

So i emailed my host and they did a upgrade . Everything looked good until

i got payments as all of them are stuck on "open".

Up until the upgrade everything went through smoothly.

I checked  the Paypal addon and the settings  looked correct. 

I did go on Cpanel and a couple of directories in file manager under Paypal addon were at 777. 

I changed them to 755 as thats what i had all the dirs at before.

 

On paypal i do have " Do not receive IPN messages (Disabled)"

I also have Auto return turned on.

 

Im sure something happened with the upgrade and thinking its a permission problem somewhere.

Any help would be appreciated.

 

 

 

Version 4.6.3 SP1



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19698 posts

Posted 10 June 2019 - 05:43 AM #2

Please make sure that the HTTP/2 protocol is supported by hosting after upgrade 


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11363 posts

Posted 10 June 2019 - 04:51 PM #3

You can apply this free addon to fix cs-cart's HTTP-2 issue on pre 4.8 versions of cs-cart:

    https://ez-ms.com/pr...p2_fix_v1.0.zip


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • mrmem
  • Member
  • Members
  • Join Date: 13-Jul 09
  • 94 posts

Posted 10 June 2019 - 05:05 PM #4

Thank you both. 

will try the addon and let you know



 
  • mrmem
  • Member
  • Members
  • Join Date: 13-Jul 09
  • 94 posts

Posted 11 June 2019 - 05:08 AM #5

installed the addon but it didnt seem to help

I also asked Host if HTTP-2 is enabled.

Was told it wasnt and if it was may cause other issues. 

 If i wanted it than they recommend upgrading to Litespeed server . 

They said they have a 14 day free trail to try it. 

Heard many say that litespeed was much faster but worried id open more issues.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19698 posts

Posted 11 June 2019 - 06:17 AM #6

I also asked Host if HTTP-2 is enabled.
Was told it wasnt and if it was may cause other issues

 

So they cannot enable HTTP/2 protocol without upgrading your server?


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11363 posts

Posted 11 June 2019 - 04:39 PM #7

installed the addon but it didnt seem to help

I also asked Host if HTTP-2 is enabled.

Was told it wasnt and if it was may cause other issues. 

 If i wanted it than they recommend upgrading to Litespeed server . 

They said they have a 14 day free trail to try it. 

Heard many say that litespeed was much faster but worried id open more issues.

so your hosting is filtering out http2 requests?  That would be really bad.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 12 June 2019 - 08:37 PM #8

I'm having the same issue with open Paypal orders the last couple days. Says this: "Accepted, awaiting ipn for processing"



 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 12 June 2019 - 08:46 PM #9

By the way, I'm using

Upgrade 4.9.3 - 4.9.3.SP1
  • Upgraded on: Feb 20, 2019


 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 12 June 2019 - 08:55 PM #10

Here's what my host said about it:

 

The apache module for http2 is not installed because it conflicts with MPM Prefork:
===
Resolving Dependencies
--> Running transaction check
---> Package ea-apache24-mod_http2.x86_64 0:2.4.39-4.4.1.cpanel will be installed
--> Processing Conflict: ea-apache24-mod_mpm_prefork-2.4.39-4.4.1.cpanel.x86_64 conflicts ea-apache24-mod_http2
--> Processing Conflict: ea-apache24-mod_http2-2.4.39-4.4.1.cpanel.x86_64 conflicts ea-apache24-mod_mpm_prefork
--> Finished Dependency Resolution
Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_http2-2.4.39-4.4.1.cpanel.x86_64
Error: ea-apache24-mod_http2 conflicts with ea-apache24-mod_mpm_prefork-2.4.39-4.4.1.cpanel.x86_64
===

We do not recommend changing the MPM away from prefork, because parts of the cPanel interface make assumptions that prefork is in use.

However, you may want to note that LiteSpeed WebServer supports HTTP 2 by default. If you would like to purchase LiteSpeed please contact the Billing Department.

That being said, if it was working before, it might not be the lack of http/2 support causing it (unless PayPal has recently begun requiring http/2). If you could provide more specific information about the issue you are having, I might be able to help determine whether or not this is the cause of the issue.

 

Any suggestions??



 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 14 June 2019 - 07:23 PM #11

Seems they resolve after a day or two or three if I just don't do anything. I read somewhere on Paypal website attempts go for four days.



 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2302 posts

Posted 14 June 2019 - 07:50 PM #12

This started to happen to us as well around the 11th until yesterday. 

Today I talked to paypal about this, and it was a problem at their side. How nice of them not to warn anybody, right?

 

I do not even see the payments in our paypal account (and still don't) but they assured me they will appear soon.


When life hands you lemons, bring on the Tequila baby!


 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 15 June 2019 - 04:00 AM #13

Thanks for the info! Good to know, it's what I was hoping for!



 
  • poppedweb
  • Authorized Reseller
  • Members
  • Join Date: 02-Aug 16
  • 547 posts

Posted 15 June 2019 - 07:20 AM #14

This started to happen to us as well around the 11th until yesterday. 

Today I talked to paypal about this, and it was a problem at their side. How nice of them not to warn anybody, right?

 

I do not even see the payments in our paypal account (and still don't) but they assured me they will appear soon.

 

Correct, they had an issue with handling payments as well as showing the balance on accounts. Seems quite a serious issue if you ask me!


PoppedWeb | sales@poppedweb.com | https://poppedweb.com
TurnKey Website Design | Add-Ons | Performance Audits | Dedicated Server Management
24/7 Support | Response within an hour (during working hours).

 
  • mrmem
  • Member
  • Members
  • Join Date: 13-Jul 09
  • 94 posts

Posted 16 June 2019 - 02:44 PM #15

I got my Paypal payments to work again. As i stated it started when i had to do a upgrade of Cpanel as i have earlier version which had reached its EOL.

I was reading through message boards and saw many have same problem back in Nov '18 when they did a auto upgrade for cpanel also.

The below message board gave me the fix. Believe the file changes are on page 2 or 3.

 

Had to make changes in  app/Tygh/Http.php file.

Once i did PAypal payments started getting the proper statuses again.

 

 

https://forum.cs-car...stoped-working/