Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgrading Via Command Line Error Rate Topic   - - - - -

 
  • melshity
  • Advanced Member
  • Members
  • Join Date: 08-May 18
  • 64 posts

Posted 03 June 2019 - 08:32 AM #1

Hi

i tray Upgrading my MV via Command Line get error 

 

PHP Warning: file_put_contents(/var/www/html/abulhoul/public_html/var/upgrade/core_log.txt): failed to open stream: Permission denied in /var/www/html/abulhoul/public_html/app/Tygh/UpgradeCenter/Log.php on line 79

2019-06-03 11:09:54: Caught an exception:  --> Smarty: Unable to load template tygh '/var/www/html/abulhoul/public_html/var/upgrade/packages//content/extra_files/validators/core_changes_confirmation.tpl' 

Upgrade process of your store has failed



 
  • soft-solid
  • Junior Member
  • Members
  • Join Date: 19-Apr 10
  • 801 posts

Posted 03 June 2019 - 10:32 AM #2

Hello

 

Please check permission to directory /var/upgrade/ and check permission to file core_log.txt

If you have access via ssh to server run command:

cd direcrtory/where/is/shop/var/upgrade

ls -al

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • melshity
  • Advanced Member
  • Members
  • Join Date: 08-May 18
  • 64 posts

Posted 03 June 2019 - 10:52 AM #3

Hello

 

Please check permission to directory /var/upgrade/ and check permission to file core_log.txt

If you have access via ssh to server run command:

cd direcrtory/where/is/shop/var/upgrade

ls -al

 

Best regards

Robert

 

i try change but get error

 

Error:        set attrs for /var/www/html/abulhoul/public_html/var/upgrade/core_log.txt: permission denied

Attached Thumbnails

  • Screen Shot 2019-06-03 at 2.50.49 PM.png


 
  • soft-solid
  • Junior Member
  • Members
  • Join Date: 19-Apr 10
  • 801 posts

Posted 03 June 2019 - 10:57 AM #4

Hello

 

It looks like that user you log on server in does not have the enough rights. Contact the server administrator.

 

Best regards

Robert


Team of SoftSolid
cs-cart.pl

 
  • melshity
  • Advanced Member
  • Members
  • Join Date: 08-May 18
  • 64 posts

Posted 03 June 2019 - 11:52 AM #5

Hello

 

It looks like that user you log on server in does not have the enough rights. Contact the server administrator.

 

Best regards

Robert

 

fixed permission but now get below error

 

+------+----------------------------+-------------+--------------+
| id   | name                       | new version | release date |
+------+----------------------------+-------------+--------------+
| core | Upgrade 4.9.3.SP1 - 4.10.1 | 4.10.1      | May 30, 2019 |
+------+----------------------------+-------------+--------------+
Select an upgrade package
  [0] core
 > 0
Do you want to create a backup? [Y,n]: Y
2019-06-03 15:35:41: Downloading "core" upgrade package
 
2019-06-03 15:35:43: Upgrade package has been downloaded and ready to install
 
(N) Notice: Upgrade package has been downloaded and ready to install
 
 
 
 
################################################################################
 
################################################################################
 
2019-06-03 15:35:43: Starting installation of the "core" upgrade package
 
2019-06-03 15:35:43: Upgrading version 4.9.3.SP1 to 4.10.1
 
2019-06-03 15:35:43: Running as user "root"
 
2019-06-03 15:35:43: Storing entry point files permissions...
 
2019-06-03 15:35:43: index.php ==> 33188 (-rw-r--r--)
 
2019-06-03 15:35:43: admin.php ==> 33188 (-rw-r--r--)
 
2019-06-03 15:35:43: api.php ==> 33188 (-rw-r--r--)
 
2019-06-03 15:35:43: vendor.php ==> 33188 (-rw-r--r--)
 
2019-06-03 15:35:43:  ==> 16877 (drwxr-xr-x)
 
2019-06-03 15:35:43: Executing pre-upgrade validators
 
2019-06-03 15:35:43: Found 2 validators at package
 
2019-06-03 15:35:43: Executing "Core Changes Confirmation" validator
 
2019-06-03 15:35:43: PHP Notice: Undefined index: id in /var/www/html/abulhoul/public_html/var/upgrade/packages/core/content/validators/CoreChangesConfirmationValidator.php on line 144
 
PHP Notice: Undefined index: id in /var/www/html/abulhoul/public_html/var/upgrade/packages/core/content/validators/CoreChangesConfirmationValidator.php on line 144
2019-06-03 15:35:43: Caught an exception:  --> Smarty: Unable to load template tygh '/var/www/html/abulhoul/public_html/var/upgrade/packages//content/extra_files/validators/core_changes_confirmation.tpl' 
Upgrade process of your store has failed