Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Duplicate Rel-Canonical On Some Pages But Not All Rate Topic   - - - - -

 
  • IsItFast
  • Senior Member
  • Members
  • Join Date: 16-Sep 08
  • 547 posts

Posted 02 June 2019 - 10:26 PM #1

Google has been doing some strange things to my rankings for some categories lately.  Essentially something I normally rank on the first page for I will get moved to the second or third page (or lower) because Google changes a relevant category page to what they say is a better page that is my home page.  But my home page doesn't really have anything to do with these search terms so it is moved down the rankings.  When I re-submit the proper url Google says it chose my homepage as canonical over what my site says is canonical.  Rankings go back to normal when I do this but with about 1000 categories it is impossible to keep track of what ones are changing and when I need to do a resubmit.  Anyway, I reached out for some SEO help and was told the following:

 

Well I just took a look at your site. It has an issue and strange at that. Here let me show you what I mean. See the image below. It has a double canonical. The fact that you have a dbl canonical is the issue. You need to fix this. This is a coding error. This double canonical is also present on all pages I check. Also all of your paginated content for comic decals, they all point to the 1st page of product as the canonical. This isn't the most optimal setup btw.

So I checked into what they said and it is true for a LOT of my category pages and even product pages.  Many have duplicate "HTML Rel-Canonical" tags from what this plug in (LinkResearchTools/Link Redirect Trace) is showing me.  Odd that about 1/4 of my page/categories/products are showing the duplicate canonical.

 

Not sure I totally understand about the comment "they all point to the 1st page of the product as canonical" either.

 

I do have the SEO ultimage add-on but disabling that doesn't seem to fix anything so that doesn't appear to be causing the issue.

 

The page I'm referring to is https://fastdecals.c...cartoon-decals/but this is happening all over the site.  Any help or input would be appreciated.


V4.3.1 with about 10,000 highly customizable products. Several mods done....some of which now come standard with CS now. (Started with V1.3.5)

V3.0 in a few other small stores.