Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Recent Frequent Crashing Rate Topic   - - - - -

 
  • SpyreDigital
  • Junior Member
  • Authorized Reseller
  • Join Date: 01-Nov 10
  • 93 posts

Posted 23 January 2019 - 01:42 AM #1

Hi all,
 
One of my clients' websites (v4.4.2) has been crashing a lot recently. It typically happens once every weekday.
 
This is the error message shown in the source when it happens:
 

<!--

Tygh\Exceptions\AException

Message

Cannot connect to the database server

Error at

app/Tygh/Providers/DatabaseProvider.php, line: 49

Backtrace

File:app/lib/vendor/pimple/pimple/src/Pimple/Container.php

Line:112

Function:Tygh\Providers\{closure}

File:app/functions/fn.database.php

Line:65

Function:offsetGet

File:app/functions/fn.control.php

Line:1021

Function:db_get_field

File:app/functions/fn.control.php

Line:944

Function:fn_get_storage_data

File:init.php

Line:119

Function:fn_allowed_for

File:index.php

Line:24

Function:require

-->

 

 

The error_log shows several lines of this just before it happens:

 

[22-Jan-2019 22:16:57 UTC] PHP Warning:  Attempt to assign property of non-object in /home/areasafe/public_html/app/Tygh/Settings.php on line 100

 

 

And then once it drops out, this:

 

[23-Jan-2019 01:22:52 UTC] PHP Warning:  Illegal string offset 'config' in /home/areasafe/public_html/app/Tygh/Registry.php on line 182
[23-Jan-2019 01:22:52 UTC] PHP Notice:  Array to string conversion in /home/areasafe/public_html/app/Tygh/Registry.php on line 182

 

 

Generally I just delete the cache files to get it working again, but obviously this is only a short term solution.

 

Any ideas?



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3776 posts

Posted 23 January 2019 - 08:36 AM #2

What PHP version?  Should be using 7.0.



 
  • SpyreDigital
  • Junior Member
  • Authorized Reseller
  • Join Date: 01-Nov 10
  • 93 posts

Posted 23 January 2019 - 08:44 AM #3

Good point. It's 5.6 at the moment.



 
  • SpyreDigital
  • Junior Member
  • Authorized Reseller
  • Join Date: 01-Nov 10
  • 93 posts

Posted 23 January 2019 - 10:09 AM #4

I just updated the staging site to PHP 7.3 and it crashed the site. I was getting a 500 error.

So I scaled it back to PHP 7 and it seems to be ok now. But I'll have to test add-ons etc I guess.