Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgrade To 4.9.1 Php Issue Rate Topic   - - - - -

 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 14 posts

Posted 17 October 2018 - 10:07 AM #1

Hi good morning,

Like says in the warning before instalation the 4.9.1 version only support the 5.6 or newer php version so I put in my server the 5.6 php version as actual.

But when I try to update this not advance and I see in core_log the following error:

2018-10-17 10:18:59: mysqldump is not available

Can someone tell me a solution for this?

 

Waiting for help,

Best regards.

 



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19051 posts

Posted 17 October 2018 - 01:03 PM #2

Contact hosting administrator and ask him to configure mysqldump


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 14 posts

Posted 23 October 2018 - 04:09 PM #3

Hi,

 

After wait a couple of minutes the upgrade advanced and I had to go to core_log to see that have completed the upgrade, but when I refresh the admin panel page show me only a white page.

 

Someone with this error to?

 

Best regards.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19051 posts

Posted 24 October 2018 - 04:35 AM #4

In the config.local.php file temporary replace

ini_set('display_errors', 0);

with

ini_set('display_errors', 1);
define('DEVELOPMENT', true);

to see error message


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 14 posts

Posted 25 October 2018 - 08:24 AM #5

I do that and show me this error:

 

Fatal error: Undefined class constant 'PARTNER' in /home/prestigeteashop/public_html/app/addons/sd_affiliate/func.php on line 1683



 
  • tingsin86
  • Junior Member
  • Trial users
  • Join Date: 29-Sep 10
  • 5 posts

Posted 25 October 2018 - 08:41 AM #6

My website is currently running an old version of CS-Cart (version 4.8.2.SP2) . 
I need update CS-Cart software to the latest version 4.9.1. 
My License with CS-Cart had been renewed. 
 
I renew it and my store show Sorry, service is temporarily unavailable. at both website and admin page.
 
view source , it show
 
Error at app/addons/sd_affiliate/func.php, line: 2
 
Tygh\Exceptions\AException       Message   Hook fn_sd_affiliate_init_company_data is not callable       Error at   app/functions/fn.control.php, line: 115       Backtrace   File:app/functions/fn.init.php   Line:258   Function:fn_set_hook       File:app/functions/fn.init.php   Line:1008   Function:fn_init_company_data       File:init.php   Line:155   Function:fn_init       File:admin3191.php   Line:25   Function:require

 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3800 posts

Posted 25 October 2018 - 08:59 AM #7

Hi good morning,

Like says in the warning before instalation the 4.9.1 version only support the 5.6 or newer php version so I put in my server the 5.6 php version as actual.

But when I try to update this not advance and I see in core_log the following error:

2018-10-17 10:18:59: mysqldump is not available

Can someone tell me a solution for this?

 

Waiting for help,

Best regards.

 

This is not an error. It is a log record that indicates that mysqldump is not available on your server. It does not cause any problems, script will just use other method to backup the database.

 

I do that and show me this error:

 

Fatal error: Undefined class constant 'PARTNER' in /home/prestigeteashop/public_html/app/addons/sd_affiliate/func.php on line 1683

 

 

 

My website is currently running an old version of CS-Cart (version 4.8.2.SP2) . 
I need update CS-Cart software to the latest version 4.9.1. 
My License with CS-Cart had been renewed. 
 
I renew it and my store show Sorry, service is temporarily unavailable. at both website and admin page.
 
view source , it show
 
Error at app/addons/sd_affiliate/func.php, line: 2
 
Tygh\Exceptions\AException       Message   Hook fn_sd_affiliate_init_company_data is not callable       Error at   app/functions/fn.control.php, line: 115       Backtrace   File:app/functions/fn.init.php   Line:258   Function:fn_set_hook       File:app/functions/fn.init.php   Line:1008   Function:fn_init_company_data       File:init.php   Line:155   Function:fn_init       File:admin3191.php   Line:25   Function:require

 

 

According to the error message the issue is related to the sd_affiliate third-party add-on. You should disable it and contact the add-on developer.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • galtinbaeva
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 06-Dec 13
  • 3303 posts

Posted 25 October 2018 - 10:46 AM #8

I do that and show me this error:

 

Fatal error: Undefined class constant 'PARTNER' in /home/prestigeteashop/public_html/app/addons/sd_affiliate/func.php on line 1683

 

Hello!

 

Please update the Affiliate and Referral add-on. We have already adapted the add-on to version 4.9.1.


Simtech Development | sales@simtechdev.com | www.simtechdev.com
CERTIFIED CS-CART PARTNER | LICENSES | DEVELOPMENT | ADD-ONS | DESIGN | UPGRADE

Google Analytics Enhanced Ecommerce - get advanced ecommerce analytics


 
  • galtinbaeva
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 06-Dec 13
  • 3303 posts

Posted 25 October 2018 - 10:48 AM #9

 

My website is currently running an old version of CS-Cart (version 4.8.2.SP2) . 
I need update CS-Cart software to the latest version 4.9.1. 
My License with CS-Cart had been renewed. 
 
I renew it and my store show Sorry, service is temporarily unavailable. at both website and admin page.
 
view source , it show
 
Error at app/addons/sd_affiliate/func.php, line: 2
 
Tygh\Exceptions\AException       Message   Hook fn_sd_affiliate_init_company_data is not callable       Error at   app/functions/fn.control.php, line: 115       Backtrace   File:app/functions/fn.init.php   Line:258   Function:fn_set_hook       File:app/functions/fn.init.php   Line:1008   Function:fn_init_company_data       File:init.php   Line:155   Function:fn_init       File:admin3191.php   Line:25   Function:require

 

 

Hello!

 

Please post a ticket in our HelpDesk https://www.simtechdev.com/helpdesk with this error. Our manager will help you.


Simtech Development | sales@simtechdev.com | www.simtechdev.com
CERTIFIED CS-CART PARTNER | LICENSES | DEVELOPMENT | ADD-ONS | DESIGN | UPGRADE

Google Analytics Enhanced Ecommerce - get advanced ecommerce analytics


 
  • tingsin86
  • Junior Member
  • Trial users
  • Join Date: 29-Sep 10
  • 5 posts

Posted 27 October 2018 - 08:27 AM #10

I send a ticket, they quote me 150USD for fixing the issue. Any better price? 

 

Hello!

 

Please post a ticket in our HelpDesk https://www.simtechdev.com/helpdesk with this error. Our manager will help you.



 
  • tingsin86
  • Junior Member
  • Trial users
  • Join Date: 29-Sep 10
  • 5 posts

Posted 29 October 2018 - 05:19 PM #11

update the Affiliate and Referral add-on.

can be update admin but my main website cannot enter. have this error below

Sorry, service is temporarily unavailable.

Smarty Compiler: Syntax error in template "/home/passiongadgets/public_html/design/themes/responsive/templates/addons/sd_affiliate/hooks/index/meta.post.tpl" on line 1 "{if $runtime.customization_mode.design == "Y" && $smarty.const.AREA == "C"}{capture name="template_content"}{if $addons.seo.status != 'A' && $config.current_url|sd_MWUxNzUyZDU1YmI4NWMyMDgyMTI2M2Jk:"aff_id"}" unknown modifier "sd_MWUxNzUyZDU1YmI4NWMyMDgyMTI2M2Jk" -->



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11248 posts

Posted 29 October 2018 - 07:34 PM #12

I send a ticket, they quote me 150USD for fixing the issue. Any better price? 

 

It's their addon.  Most other developers will not touch another's code unless the developer is out of business and/or the merchant wants extensions that the vendor is not able/willing to provide.  Note also that SimTech has started to release their addons in encoded form so that it is quite difficult to modify or review them by others.  I.e. they are no longer open source.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • tingsin86
  • Junior Member
  • Trial users
  • Join Date: 29-Sep 10
  • 5 posts

Posted 30 October 2018 - 05:40 AM #13

I have update Simtechdev affiliate and referral v4.8.0.3 still cannot work, i have to disable it. 

Waste my purchase for $198. 

Now cs-cart able to update 4.9.1 but randomly have script error. 



 
  • galtinbaeva
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 06-Dec 13
  • 3303 posts

Posted 31 October 2018 - 06:32 AM #14

I have update Simtechdev affiliate and referral v4.8.0.3 still cannot work, i have to disable it. 

Waste my purchase for $198. 

Now cs-cart able to update 4.9.1 but randomly have script error. 

 

Hello!

 

I want to apologize for the USD 150 quote. It was made by mistake, we do not charge for such issues in our add-ons.

 

We have already updated our add-on in your store. Now it is working correctly.

 

If you face any issues with our add-ons or have some suggestions, you can contact me directly or made a post in the special add-on's topic. This way I definitely won't miss it.


Simtech Development | sales@simtechdev.com | www.simtechdev.com
CERTIFIED CS-CART PARTNER | LICENSES | DEVELOPMENT | ADD-ONS | DESIGN | UPGRADE

Google Analytics Enhanced Ecommerce - get advanced ecommerce analytics