Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgrade From 4.7.4 To 4.8.1 Failed Rate Topic   - - - - -

 
  • TTapio
  • Newbie
  • Members
  • Join Date: 21-Jun 18
  • 14 posts

Posted 21 June 2018 - 08:24 AM #1

It's been so far easy process to upgrade. Last upgrade 4.7.4 I did's see GDPR addon at all (yes, tried to search). After getting in contact with support they obviously installed GDPR addon manually and it was available.

 

Now after I tried to upgrade from 4.7.4 to 4.8.1 I got n error as shown in JPEG file. I have multistore but all stores use english at the moment and I don't get it why the error message contain reference to language FR (French obviously). The upgrade process failed and not sure how to proceed. 

 

I'm able to login to admin area but I didn't restore old files back yet. Trying to avoid downtime if such happen.error.JPG


CS-Cart Ultimate 4.8.1 SP1


 
  • imac
  • CTO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2040 posts

Posted 21 June 2018 - 10:53 AM #2

It's been so far easy process to upgrade. Last upgrade 4.7.4 I did's see GDPR addon at all (yes, tried to search). After getting in contact with support they obviously installed GDPR addon manually and it was available.

 

Now after I tried to upgrade from 4.7.4 to 4.8.1 I got n error as shown in JPEG file. I have multistore but all stores use english at the moment and I don't get it why the error message contain reference to language FR (French obviously). The upgrade process failed and not sure how to proceed. 

 

I'm able to login to admin area but I didn't restore old files back yet. Trying to avoid downtime if such happen.attachicon.gif error.JPG

Hi. unfortunately there was a bug in upgrade.

So in order to fix this please do the following:

1. Restore the backup of 4.7.4

2. Refresh the upgrade packages.

3. Make the upgrade one again

Everything should be Ok.


Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • TTapio
  • Newbie
  • Members
  • Join Date: 21-Jun 18
  • 14 posts

Posted 21 June 2018 - 12:47 PM #3

Hi,

 

I did as recommended. Didn't work. I got exactly same error.

 

1. I did restore backup

2. Refresh upgrade

3. Did upgrade again and got very same error.

 

However, I still can used admin area normally. Able to login.


CS-Cart Ultimate 4.8.1 SP1


 
  • gasngrills
  • Senior Member
  • Members
  • Join Date: 23-Feb 08
  • 239 posts

Posted 21 June 2018 - 02:07 PM #4

All I see after the upgrade is text in admin panel no images and can't restore, any ideas?


CS-Cart 4.5.1


 
  • Darius
  • Douchebag
  • Members
  • Join Date: 20-Apr 08
  • 3214 posts

Posted 21 June 2018 - 02:51 PM #5

try manually deleting /var/cache

 

All I see after the upgrade is text in admin panel no images and can't restore, any ideas?



 
  • gasngrills
  • Senior Member
  • Members
  • Join Date: 23-Feb 08
  • 239 posts

Posted 21 June 2018 - 04:26 PM #6

try manually deleting /var/cache

 I have tried that still o go, this is the first time I encounter any issues with the update, the site is down is so is my business not good


CS-Cart 4.5.1


 
  • gasngrills
  • Senior Member
  • Members
  • Join Date: 23-Feb 08
  • 239 posts

Posted 21 June 2018 - 04:39 PM #7

I have contacted support and they fixed it, it was something to do with CDN not providing the cache files


CS-Cart 4.5.1


 
  • TTapio
  • Newbie
  • Members
  • Join Date: 21-Jun 18
  • 14 posts

Posted 24 June 2018 - 12:59 PM #8

Here's final results and what I did to fix it. Support sadly didn't give any working solution how to get upgrade done. Bug in upgrade? I think it's more like bug in CS Cart itself.

 

If your upgrade from 4.7.4 to 4.8.1 fails and you get same message as above.

 

1. While error was linked to language file(s). I took closer look to it. I have several languages (official ones) in use. First main language is english in all sites + additionally 5 other languages.

 

2. I did uninstall ALL additional languages and left english only.

 

3. Back to upgrade center and select upgrade etc. normally. 

 

4. Upgrade was successful without any errors linked to languages.

 

Someone may find exact cause in language files as error states.

Anyways above solution helped me.


CS-Cart Ultimate 4.8.1 SP1


 

Posted 25 June 2018 - 06:59 AM #9

Here's final results and what I did to fix it. Support sadly didn't give any working solution how to get upgrade done. Bug in upgrade? I think it's more like bug in CS Cart itself.

 

If your upgrade from 4.7.4 to 4.8.1 fails and you get same message as above.

 

1. While error was linked to language file(s). I took closer look to it. I have several languages (official ones) in use. First main language is english in all sites + additionally 5 other languages.

 

2. I did uninstall ALL additional languages and left english only.

 

3. Back to upgrade center and select upgrade etc. normally. 

 

4. Upgrade was successful without any errors linked to languages.

 

Someone may find exact cause in language files as error states.

Anyways above solution helped me.

 

One of the database migrations in the upgrade package did work if there was an apostrophe (') in the GDPR add-on language variables (for example in French and Italian translations).

 

This issue was fixed last week. You should revert the upgrade and install it once again per imac instruction in the first reply of this topic.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • kostakis
  • Newbie
  • Members
  • Join Date: 18-Nov 12
  • 4 posts

Posted 25 June 2018 - 07:33 AM #10

Hello, I have rename admin.php to index0.php. At last minutes of upgrade windows upgrade pause at copy index0.php file!

I have done this 3-4 times, clear cache, clear admin log, timeout 3600 etc but the problem is here! Any help please?



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 10945 posts

Posted 25 June 2018 - 07:22 PM #11

Did you adjust the corresponding config.local.php $config['admin_url'] setting to be index0.php?


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • kostakis
  • Newbie
  • Members
  • Join Date: 18-Nov 12
  • 4 posts

Posted 26 June 2018 - 10:33 AM #12

Did you adjust the corresponding config.local.php $config['admin_url'] setting to be index0.php?

Yes of course, I have change this before 6 years and I have done update from 2.2.4 to 4.7.4

After 4.3.x update every time a have lot of errors!



 
  • TTapio
  • Newbie
  • Members
  • Join Date: 21-Jun 18
  • 14 posts

Posted 26 June 2018 - 10:39 AM #13

One of the database migrations in the upgrade package did work if there was an apostrophe (') in the GDPR add-on language variables (for example in French and Italian translations).

 

This issue was fixed last week. You should revert the upgrade and install it once again per imac instruction in the first reply of this topic.

 

I tried the way as instructed. Didn't work for me. Even after restoring upgrade package. The error was the very same.

Good if it works for some without errors and restoring the backup works. Looks like I am the only one who hard hard time with it.

 

I still have one major issue with CS Cart, which doesn't work at all. I've sent message to support about it.


CS-Cart Ultimate 4.8.1 SP1


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 10945 posts

Posted 26 June 2018 - 06:38 PM #14

Maybe you could post an example of the errors you are seeing?  Otherwise, we're all guessing.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 8 posts

Posted 09 July 2018 - 08:20 AM #15

Hi,

 

After upgrade to the 4.8.1 version, the search period in sales reports dont work, I choose for example the current month and hit search and the results is the all sales in the store and not the current month.

 

Can you say me a solution?

 

Best regards.



 

Posted 09 July 2018 - 10:43 AM #16

Hi,

 

After upgrade to the 4.8.1 version, the search period in sales reports dont work, I choose for example the current month and hit search and the results is the all sales in the store and not the current month.

 

Can you say me a solution?

 

Best regards.

 

Please refer to the following topic:

 

https://forum.cs-car...l-period-serch/


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 8 posts

Posted 09 July 2018 - 04:10 PM #17

Please refer to the following topic:

 

https://forum.cs-car...l-period-serch/

 

Thank you, problem solved.



 
  • lsublimes
  • Newbie
  • Members
  • Join Date: 09-Jul 18
  • 8 posts

Posted 10 July 2018 - 03:58 PM #18

Hi,

Can you say me a solution for this error?

 

Best regards.

 

update.jpg



 

Posted 12 July 2018 - 11:01 AM #19

Hi,

Can you say me a solution for this error?

 

Best regards.

 

update.jpg

 

You should restore the backup that was created when you initially tried upgrading the installation. After that try upgrading again.

 

If you need assistance with this, please contact us via Help desk.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation