Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Web Redirection Rate Topic   - - - - -

 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 11 June 2018 - 04:02 PM #1

Hello,

 

I got this message:

 

Your URL performed 2 redirects! While redirects are typically not advisable (as they can affect search engine indexing issues and adversely affect site loading time), one redirect may be acceptable, particularly if the URL is redirecting from a non-www version to its www version, or vice-versa.

 

from: http://mysite.com/ to: http://www.mysite.com/

from: http://www.mysite.com/ to: https://www.mysite.com/

 

 

How to fix it and where?

 

Regards



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3640 posts

Posted 11 June 2018 - 07:50 PM #2

Check /config.local.php and make sure the domains are correct.



 
  • Mongoose
  • Senior Member
  • Members
  • Join Date: 08-Mar 13
  • 958 posts

Posted 11 June 2018 - 09:08 PM #3

Check /config.local.php and make sure the domains are correct.

 

What piece of code you suggest he/she amends?


CS Cart Evangelist - running CS Cart 4.7.4 in three domains


 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3640 posts

Posted 11 June 2018 - 11:43 PM #4

What piece of code you suggest he/she amends?

 

The only ones that has his/her domain/url.



 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 12 June 2018 - 05:59 AM #5

The only ones that has his/her domain/url.

 

In config.local.php I can see :

 

// Host and directory where software is installed on no-secure server
$config['http_host'] = 'www.mysite.com';
$config['http_path'] = '';
 
// Host and directory where software is installed on secure server
$config['https_host'] = 'www.mysite.com';
$config['https_path'] = '';
 
Don't see anything wrong.
 
Thank you for help.


 
  • johnbol1
  • Never Re
  • Members
  • Join Date: 23-Feb 10
  • 4342 posts

Posted 12 June 2018 - 08:59 AM #6

Hello,

 

I got this message:

 

Your URL performed 2 redirects! While redirects are typically not advisable (as they can affect search engine indexing issues and adversely affect site loading time), one redirect may be acceptable, particularly if the URL is redirecting from a non-www version to its www version, or vice-versa.

 

from: http://mysite.com/to: http://www.mysite.com/

from: http://www.mysite.com/to: https://www.mysite.com/

 

 

How to fix it and where?

 

Regards

Where did this message come from, who sent it.

Check your .htaccess


Custom printed hi visibility clothing sale the UK's online hivis safety shop
v4.5.2


 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 12 June 2018 - 10:34 AM #7

Where did this message come from, who sent it.

Check your .htaccess

 

I have tried this tool here: https://seositecheckup.com/seo-audit

 

and got message that I have two redirects. I will check .htaccess.



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3640 posts

Posted 12 June 2018 - 03:51 PM #8

Also check the same in admin.

 

domain.png



 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 12 June 2018 - 07:32 PM #9

Also check the same in admin.

 

attachicon.gif domain.png

 

I don't see on Multivendor this settings. Below added a part of my .htaccess file. Is there something wrong?

 

RewriteEngine on
# Please note that RewriteBase setting is obsolete use it only in case you experience  some problems with SEO addon.
# Some hostings require RewriteBase to be uncommented
# Example:
# So "RewriteBase" should be:
# RewriteBase /store/cart
# RewriteBase /
Options -MultiViews
 
RewriteRule ^init.php$ - [F,L,NC]
 
AddEncoding gzip .gz
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_FILENAME} \.(js|css)$
RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}.gz -f
RewriteRule ^(.*)$ $1.gz [QSA,L]
RewriteCond %{REQUEST_URI} ^api/(.*)$ [or]
RewriteCond %{REQUEST_URI} .*/api/(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .*api/(.*)$ api.php?_d=$1&ajax_custom=1 [L,QSA]
RewriteCond %{REQUEST_URI} \.(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff|yml|xml)$ [or]
RewriteCond %{REQUEST_URI} store_closed.html$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*?)\/(.*)$ $2 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L,QSA]


 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2123 posts

Posted 12 June 2018 - 07:39 PM #10

What's your websites url?


When life hands you lemons, bring on the Tequila baby!


 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 12 June 2018 - 07:43 PM #11

What's your websites url?

 

I sent PM.



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3640 posts

Posted 12 June 2018 - 08:12 PM #12

I can't see any issues but there is a difference between your htaccess and the original htaccess from Mult-Vendor 4.7.4.  I don't know if you just didn't post it all or what.?

 

Mult-Vendor 4.7.4 htaccess:

DirectoryIndex index.html index.php

<IfModule mod_deflate.c>
    # Compress HTML, CSS, JavaScript, Text, XML, fonts
    AddOutputFilterByType DEFLATE application/javascript application/x-javascript text/javascript application/json
    AddOutputFilterByType DEFLATE application/x-font application/x-font-opentype application/x-font-otf application/x-font-truetype application/x-font-ttf font/opentype font/otf font/ttf application/x-woff application/x-font-woff
    AddOutputFilterByType DEFLATE text/css text/html text/plain

    <IfModule mod_headers.c>
        # Remove browser bugs (only needed for really old browsers)
        BrowserMatch ^Mozilla/4 gzip-only-text/html
        BrowserMatch ^Mozilla/4\.0[678] no-gzip
        BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
        Header append Vary User-Agent
    </IfModule>
</IfModule>

<IfModule mod_headers.c>
    <FilesMatch "\.(ttf|ttc|otf|eot|woff|css|png|gif|ico|jpe?g)$">
        Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
</IfModule>

# Cache all images for 2 weeks
<IfModule mod_expires.c>
    <FilesMatch "\.(jpg|jpeg|png|gif|tiff|bmp|js|css)$">
        ExpiresActive on
        ExpiresDefault "access plus 2 weeks"
    </FilesMatch>
</IfModule>

<IfModule mod_headers.c>
    <filesMatch "\.(gif|png|jpg|jpeg|ico|js|css)$">
        Header set Cache-Control "max-age=1209600"
    </filesMatch>
</IfModule>


<IfModule mod_rewrite.c>
RewriteEngine on
# Please note that RewriteBase setting is obsolete use it only in case you experience  some problems with SEO addon.
# Some hostings require RewriteBase to be uncommented
# Example:
# Your store url is http://www.yourcompany.com/store/cart
# So "RewriteBase" should be:
# RewriteBase /store/cart
# RewriteBase /

# This setting is commented out because it might cause an error on some servers where MultiViews override is forbidden.
# Enabling MultiViews can lead to unexpected results if an URI (for example, an URI of a SEO name)
# matches the structure of folders in the root directory of the store.
# If you have such URIs, please uncomment the following lines
# <IfModule mod_negotiation.c>
#    Options -MultiViews
# </IfModule>

RewriteRule ^init.php$ - [F,L,NC]

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_URI} ^api/(.*)$ [or]
RewriteCond %{REQUEST_URI} .*/api/(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .*api/(.*)$ api.php?_d=$1 [L,QSA]

RewriteCond %{REQUEST_URI} \.(png|gif|ico|swf|jpe?g|js|css|ttf|svg|eot|woff|yml|xml)$ [NC,or]
RewriteCond %{REQUEST_URI} store_closed.html$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*?)\/(.*)$ $2 [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L,QSA]

</IfModule>

# This prevents possible problems when downloading files
<IfModule mod_php5.c>
    php_flag zlib.output_compression Off
</IfModule>


 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2123 posts

Posted 12 June 2018 - 08:20 PM #13

I don't think you have an issue. I think you put the url: http://yoursite.com into the testing tool and your website correctly redirects to https://www.yoursite.com 

 

Try testing it as https://www.yoursite.com and the warning should be gone.


When life hands you lemons, bring on the Tequila baby!


 
  • memel
  • Advanced Member
  • Members
  • Join Date: 29-May 17
  • 95 posts

Posted 13 June 2018 - 05:32 AM #14

I don't think you have an issue. I think you put the url: http://yoursite.com into the testing tool and your website correctly redirects to https://www.yoursite.com 

 

Try testing it as https://www.yoursite.com and the warning should be gone.

 

You are totally right!  :-)

Thank you everyone for help.



 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2123 posts

Posted 13 June 2018 - 01:53 PM #15

Sure thing :)


When life hands you lemons, bring on the Tequila baby!