Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Issues After Upgrade To 4.7.2 Rate Topic   - - - - -

 
  • haktel
  • Advanced Member
  • Members
  • Join Date: 21-Feb 17
  • 117 posts

Posted 24 February 2018 - 08:08 PM #1

Hi,

 

I have today updated to 4.7.2.sp1..

 

Now I have no user accounts.. its show the user created but if you want sign is no acces possible..?

 

Why.??

 

here a sample from errorlog:

/var/www/vhosts/ebuymazon.com/httpdocs/app/addons/2lm_consents/controllers/frontend/profiles.post.php on line 23\n', referer: http://www.ebuymazon.com/profiles-add/
[Sat Feb 24 14:08:52.195586 2018] [proxy_fcgi:error] [pid 17127:tid 139640619083520] [client 37.24.158.171:49702] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...section=general
[Sat Feb 24 14:09:48.091766 2018] [proxy_fcgi:error] [pid 17127:tid 139640669439744] [client 37.24.158.171:49736] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\nPHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 97\nPHP message: PHP Notice:  Undefined index: password in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 98\n', referer: http://www.ebuymazon.com/checkout/
[Sat Feb 24 14:11:10.073610 2018] [proxy_fcgi:error] [pid 17127:tid 139640804427520] [client 37.24.158.171:49625] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon.com/
[Sat Feb 24 14:11:37.391844 2018] [proxy_fcgi:error] [pid 17127:tid 139640694617856] [client 37.24.158.171:49685] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon.com/checkout/
[Sat Feb 24 14:11:55.434574 2018] [proxy_fcgi:error] [pid 17127:tid 139640669439744] [client 37.24.158.171:49620] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...checkout/?sl=en
[Sat Feb 24 14:18:15.607819 2018] [proxy_fcgi:error] [pid 17127:tid 139640652654336] [client 37.24.158.171:49728] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...checkout/?sl=en
 
 
regards
 
 
 


 
  • oleg.gorshkov
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 06-Dec 13
  • 3078 posts

Posted 26 February 2018 - 06:13 AM #2

 

Hi,

 

I have today updated to 4.7.2.sp1..

 

Now I have no user accounts.. its show the user created but if you want sign is no acces possible..?

 

Why.??

 

here a sample from errorlog:

/var/www/vhosts/ebuymazon.com/httpdocs/app/addons/2lm_consents/controllers/frontend/profiles.post.php on line 23\n', referer: http://www.ebuymazon.com/profiles-add/
[Sat Feb 24 14:08:52.195586 2018] [proxy_fcgi:error] [pid 17127:tid 139640619083520] [client 37.24.158.171:49702] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...section=general
[Sat Feb 24 14:09:48.091766 2018] [proxy_fcgi:error] [pid 17127:tid 139640669439744] [client 37.24.158.171:49736] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\nPHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 97\nPHP message: PHP Notice:  Undefined index: password in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 98\n', referer: http://www.ebuymazon.com/checkout/
[Sat Feb 24 14:11:10.073610 2018] [proxy_fcgi:error] [pid 17127:tid 139640804427520] [client 37.24.158.171:49625] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon.com/
[Sat Feb 24 14:11:37.391844 2018] [proxy_fcgi:error] [pid 17127:tid 139640694617856] [client 37.24.158.171:49685] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon.com/checkout/
[Sat Feb 24 14:11:55.434574 2018] [proxy_fcgi:error] [pid 17127:tid 139640669439744] [client 37.24.158.171:49620] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...checkout/?sl=en
[Sat Feb 24 14:18:15.607819 2018] [proxy_fcgi:error] [pid 17127:tid 139640652654336] [client 37.24.158.171:49728] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: user_id in /var/www/vhosts/ebuymazon.com/httpdocs/app/controllers/common/auth.php on line 63\n', referer: http://www.ebuymazon...checkout/?sl=en
 
 
regards

 

 

Hello!

 

First of all, try to disable the 2lm_consents add-on.


Simtech Development | sales@simtechdev.com | www.simtechdev.com
CERTIFIED CS-CART PARTNER | LICENSES | DEVELOPMENT | ADD-ONS | DESIGN | UPGRADE

Mega SEO Package - All you need for your SEO


 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 879 posts

Posted 27 February 2018 - 11:36 AM #3

I upgraded a couple of days ago from 4.7.1 to 4.7.2 sp2 and all seemed to be OK then my website crashed.

 

This is the error that was showing up in /home/mydomain/public_html/error_log

 

[27-Feb-2018 10:19:24 UTC] PHP Parse error:  syntax error, unexpected 'Content' (T_STRING), expecting ',' or ';' in /home/samhober/public_html/app/functions/fn.common.php on line 1045

 

Note to find the error I used comparision software.

 

I deleted the code and pasted in the same code (from a different download) without an error and my website is back online.

 

My question is how would I have gotten this error? Was something done wrong while upgrading?

 

So far I am OK...


Version 4.8.1


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 10952 posts

Posted 27 February 2018 - 07:16 PM #4

Would have to look at the original file to see what was wrong.  But I seriously doubt that the code was distributed with a syntax error in that file and the md5 validation of files in a "package" usually verify the integrity of those files.

 

Is it possible either you or your developer fat-fingered that file and introduced the syntax error?  

 

I would also expect this to have been seen during the upgrade since the fn_start_scorller() function is used when outputting info for the progress bar.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • Traveler
  • Senior Member
  • Members
  • Join Date: 02-Feb 07
  • 879 posts

Posted 28 February 2018 - 07:58 AM #5

Quite possible our support person made a mistake = although he doesn't agree.... smiling.

 

Thank you for your thoughts.


Version 4.8.1


 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3680 posts

Posted 02 April 2018 - 06:47 PM #6

I just had the same issue as Traveler and it appears to be a hack.  It was also reported in this thread back in 2014 http://forum.cs-cart...ownhelp-needed/
 
The error:

[02-Apr-2018 18:37:28 UTC] PHP Parse error:  syntax error, unexpected 'Content' (T_STRING), expecting ',' or ';' in /home/user/public_html/app/functions/fn.common.php on line 1045

Code induced:

        <head><meta http-equiv="Content-Type" content="text/html; charset=gb18030"><title>" . PRODUCT_NAME . "</title>
        

Code supposed to be:

        <head><title>" . PRODUCT_NAME . "</title>
        <meta http-equiv='content-type' content='text/html; charset=" . CHARSET . "'>

Still searching because when I change it to the correct code it automatically changes back.



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3680 posts

Posted 02 April 2018 - 07:30 PM #7

Okay, this is a false alarm at least in my case.  The "charset=gb18030" is the encoding that was being saved by cpanel's file editor.

 

This must be an issue with cpanel because a lot of files are opening with gb18030.



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3680 posts

Posted 02 April 2018 - 08:26 PM #8

Update:  I couldn't save the file in cPanel's editor because it kept saving as gb18030 and changing the code.  I ended up having to edit the file via ftp.