Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Php 7.0 Or 7.1 Or 7.2? Rate Topic   - - - - -

 

Posted 17 January 2018 - 12:12 AM #1

I am running the latest version of CS-Cart Pro.

 

Having just switched web hosts, I now have the ability to run my site on PHP 7 (my former host wouldn't allow me to have some sites on PHP 7 at the same time as others that were still on 5).

 

So, does it matter whether I choose 7.0, or 7.1 or 7.2? All of those are options in my PHP manger.

 

Thanks.



 
  • martfox
  • Member
  • Authorized Reseller
  • Join Date: 15-Jan 10
  • 552 posts

Posted 17 January 2018 - 12:28 AM #2



 

So, does it matter whether I choose 7.0, or 7.1 or 7.2? All of those are options in my PHP manger.

 

.

 

 

 

Each newer version has some bug fixies, improvements etc.


CS-Cart with 1 Year FREE Web Hosting | CS-Cart optimized SSD Cloud VPS Servers from €10.00/month
.
VPS SSD Cloud from €10.00 *** Dedicated Servers *** CS-Cart Authorized Reseller and Web Hosting Provider


 

Posted 17 January 2018 - 12:30 AM #3

So basically just go with the highest...



 

Posted 17 January 2018 - 08:01 AM #4

Look at CS-Cart Requirements page; http://docs.cs-cart....quirements.html

 

currently only support up tp PHP 7.1


John Carroll
My Webshop: Alpha Spas

 
  • Flow
  • Super Duper and Amazingly Sexy Senior
  • Members
  • Join Date: 13-Oct 10
  • 2099 posts

Posted 17 January 2018 - 09:33 AM #5

7.2 gives many errors. Go for 7.1


When life hands you lemons, bring on the Tequila baby!


 

Posted 17 January 2018 - 12:24 PM #6

7.2 gives many errors. Go for 7.1

 Thank you!



 
  • crazyshark20
  • Junior Member
  • Members
  • Join Date: 19-Aug 09
  • 194 posts

Posted 21 January 2018 - 07:44 PM #7

Hi which php 7.1 version best?? I use php 7.1.4 but got some error

 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3617 posts

Posted 21 January 2018 - 09:19 PM #8

Hi which php 7.1 version best?? I use php 7.1.4 but got some error

 

Your errors may or may not be related to PHP version so I would start and new thread with the errors.



 
  • martfox
  • Member
  • Authorized Reseller
  • Join Date: 15-Jan 10
  • 552 posts

Posted 21 January 2018 - 10:59 PM #9

Hi which php 7.1 version best?? I use php 7.1.4 but got some error

 

Which errors do you get? Can you post some examples here?


CS-Cart with 1 Year FREE Web Hosting | CS-Cart optimized SSD Cloud VPS Servers from €10.00/month
.
VPS SSD Cloud from €10.00 *** Dedicated Servers *** CS-Cart Authorized Reseller and Web Hosting Provider


 
  • olidev
  • Newbie
  • Trial users
  • Join Date: 18-Apr 18
  • 1 posts

Posted 18 April 2018 - 07:29 AM #10

Each new PHP version has some fixes and improvement in code structure or performance. For example, there was a huge difference in performance between 5.6 and 7.0 but only slight improvement in performance between 7.0 and 7.2. I have used PHP 7.2 on my Cloudways hosting server. They have a custom stack that consists of varnish, memcached, redis and php-fpm. I upgraded directly from 5.6 to 7.2 and noticed a huge difference in performance. My website used to load in 2.2s but now loads in 1.1s.