Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Product Filters Going Directly To Search. Rate Topic   - - - - -

 
  • hardin
  • Newbie
  • Members
  • Join Date: 10-Feb 14
  • 4 posts

Posted 11 December 2017 - 12:21 PM #1

Hi guys,

 

We recently moved to a new server and we noticed a problem with the product filters.

 

When using the filters in a category the user gets redirected to search results and all products corresponding to the selected filters are shown (regardless of category).

 

Example: http://motoarebarci....nti-yamaha.html(just play around with the filters)

 

I looked in horizontal_filters.tpl and i'm guessing the problem has something to do with:

 

{script src="js/tygh/product_filters.js"}
 
{if $block.type == "product_filters"}
    {$ajax_div_ids = "product_filters_*,products_search_*,category_products_*,product_features_*,breadcrumbs_*,currencies_*,languages_*,selected_filters_*"}
    {$curl = $config.current_url}
{else}
    {$curl = "products.search"|fn_url}
    {$ajax_div_ids = ""}
{/if}
 
Any idea what the problem may be and how to fix it? Apart from some styling i made no modifications.
 

 



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19161 posts

Posted 11 December 2017 - 01:57 PM #2

Looks like your store-front is closed for public


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • hardin
  • Newbie
  • Members
  • Join Date: 10-Feb 14
  • 4 posts

Posted 11 December 2017 - 02:13 PM #3

Looks like your store-front is closed for public

It sould be visible now.

 

I checked the horizontal_filters.tpl on the demo site, it's identical to mine. The problem must lie someplace else.

 

Running 4.6.3SP1



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19161 posts

Posted 12 December 2017 - 06:08 AM #4

It sould be visible now.

 

I checked the horizontal_filters.tpl on the demo site, it's identical to mine. The problem must lie someplace else.

 

Running 4.6.3SP1

 

Yes, looks like a bug. Please post it to the bug tracker

 

http://forum.cs-cart.com/tracker/


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • hardin
  • Newbie
  • Members
  • Join Date: 10-Feb 14
  • 4 posts

Posted 13 December 2017 - 11:32 AM #5

Still no answer on the bug tracker.

 

I observed that the url forms correctly when using filters in a category with no products, check out: http://motoarebarci.ro/elice-ro.html

 

This gets me thinking it's not a server problem, any idea on where to look next?

 

Running 4.6.3SP1 with PHP 7.1.7 (it reproduces on 5.6.3 too)



 
  • hardin
  • Newbie
  • Members
  • Join Date: 10-Feb 14
  • 4 posts

Posted 13 December 2017 - 03:25 PM #6

I have resolved the issue.

There were some custom modifications in sorting.tpl i was not aware of. Thread may be closed.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19161 posts

Posted 14 December 2017 - 05:39 AM #7

Thank you for keeping us updated


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.