Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Email Setup Rate Topic   - - - - -

 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 26 June 2017 - 10:59 PM #1

Recently had my server moved from Wiredtree to Liquid Web and have run into several issues and need some help. LW support hasn't been useful much at all.

 

1) Main issue is the "Settings: Email" page. Was using smtp with tls and authentication on Wiredtree now I get no email no matter what settings I try and I've tried many, phpmail doesn't work either. They all return the same message:

 

"ErrorOops, something went wrong (Internal Server Error). Please try again."

 

What would be required of the server to make this work? I'm not sure LW would have set this up right as I found other things that were not setup correctly. Or is this a common result of such a move?

 

2) Google recaptcha no longer works. and you get this message:

 

"ErrorIncorrect or missing confirmation code"    So, I turned it off for now.

 

Grateful for any insight into these issues!



 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 26 June 2017 - 11:59 PM #2

BTW, using the latest version of cs-cart, php7, dedicated server.

 

SMTP mail working for orders and notifications, but it seems the Newsletter addon is a problem. I get Internal Server Error when saving or trying to send a newsletter.

 

When trying to use the send test email in the Newsletter addon I get this: "ErrorOops, something went wrong (Internal Server Error). Please try again."
 

When trying to sign up for mailing list during checkout I get this: "ErrorMessage could not be sent.Mailer Error: SMTP connect() failed."



 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3809 posts

Posted 27 June 2017 - 12:48 PM #3

The problem requires examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record  link on the Access information page of your Help Desk account so that we could examine the issue.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • dotell
  • Junior Member
  • Trial users
  • Join Date: 21-Oct 09
  • 216 posts

Posted 28 June 2017 - 07:01 AM #4

I sort of figured out what the problem was with the newsletters. I was able to create and send a NEW newsletter via test send and regular mail list sending. I still cant send out old newsletters though, for some reason the old ones don't work at all.



 
  • hammiau
  • Newbie
  • Trial users
  • Join Date: 19-Mar 15
  • 10 posts

Posted 23 October 2019 - 08:58 AM #5

I have the exact situation! I even had same error by testing a new customer with SMTP settings! Changed to phpmail without SMTP worked out - however, is not in my interest. I want SMTP!

 

No newsletter are going out - same error no matter which setting used: phpmail, sendmail or smtp. I'm 1000% sure my mail server is working by the book - tested and retested. All DKIM, SPF, DMARC and MX are set properly! I'm talking about a VPS. It has to be something related with CS-Cart!

 

ErrorMessage could not be sent.
Mailer Error: SMTP connect() failed



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11424 posts

Posted 23 October 2019 - 07:18 PM #6

Generally a "connect() failed" message would be caused by either the hostname of the SMTP server or the Port number being bad.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.