Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgraded To 4.5.2.sp2, Paypal Is Causing Issues Rate Topic   - - - - -

 
  • quarba
  • Member
  • Members
  • Join Date: 05-Sep 14
  • 23 posts

Posted 11 April 2017 - 09:58 AM #1

Hi all,

 

We have just upgraded our store to 4.5.2.SP2. I have to say, the last few upgrades were the smoothest upgrades we have ever done on cs cart. Anyway I digress.

 

We are having an issue with our Paypal intergration. I have attached two screenshots of two customer orders, one with Paypal and one is a card payment. They are both fo the same item (£7.49) and they have both paid £0.99 for shipping. The total for each order is £8.48.

 

The card payments work fine and nothing has changed post upgrade. The Paypal payments we are getting do not show any Shipping cost under the sub total. This is then having a knock on effect when we sync the orders to our stock managament system. Does anyone know why this has happended as it was working yesterday before the upgrade and this issue has shown itself on every Paypal order when a customer has paid for shipping and used Paypal since the upgrade from 4.4.3 yesterday.

 

Also, I was keen to try the new "Use In-Context Checkout" setting within Paypal, however when we activate this settings, when clicking Paypal in the checkout, a new window opens, however this new window never connects to Paypal and just shows the padlock/loading screen.

 

I dont know if these are linked? We would apreached some help as the upgrade has broken how Paypal works and is now not set up the same as before we upgraded.

 

Any help would be greatly receveid.

Attached Thumbnails

  • Card Payment.JPG
  • Paypal Payment.JPG


 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 11 April 2017 - 11:42 AM #2

The problem requires examination on your server. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record  link on the Access information page of your Help Desk account so that we could examine the issue.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • quarba
  • Member
  • Members
  • Join Date: 05-Sep 14
  • 23 posts

Posted 12 April 2017 - 01:07 PM #3

 

We placed two test orders in your store (orders #102245 and #102254) and reproduced the issue, but failed to reproduce it in default CS-Cart 4.5.2.SP2 version with same settings.

Examination of this issue is estimated at 10-20 support credits. Let me know if we can proceed.

You can also try disabling third-party add-ons and check if the issue appears again after that.

Thank you.

 

So this is the ticket response from cs cart. Does anyone have any ideas on what this could be as it was working fine before we upgraded our store from 4.4.3.

 

We have noticed that this issue only affects Paypal payments and today we noticed that this only affects our express shipping method at £0.99p. We took a Paypal payment for a next day delivery (Charge was £7), and this order was not affected by the above issue.

 

Thank you in advance for any help,

 

Luke