Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Enable Ssl Frontend Skin Error Rate Topic   - - - - -

 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 27 March 2017 - 05:17 AM #1

My site is normal but when i enable SSL frontend skin error (please view image), Admin still worked and i also checked SSL working them same both link http & https, any one help me fix skin, thank you very much!

 

NSTech_Shopping_Store_-_2017-03-27_11.56



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3987 posts

Posted 27 March 2017 - 05:23 AM #2

Try clearing cache.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 22183 posts

Posted 27 March 2017 - 07:01 AM #3

Try to delete the var/cache directory. If it does not help, possibly SSL is not installed correctly


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 28 March 2017 - 03:05 AM #4

I installed cs-cart v2.1.5 with default red skin and already deleted var/cache but still error. My admin portal is normal :(



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12091 posts

Posted 28 March 2017 - 06:18 PM #5

I would guess that you have some .htaccess or other limiting factor that is not allowing your css files (note that in V2 they are NOT consolidated to single file) are not able to be read via https.


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 31 March 2017 - 04:07 AM #6

This is my .htaccess please check help me @tbirnseth

 

order allow,deny
allow from all

# Web Optimizer options
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^(.*)\.wo[0-9]+\.(js|php)$ $1.$2
</IfModule>
# Web Optimizer end
DirectoryIndex index.html index.php

<IfModule mod_rewrite.c>
RewriteEngine on

# Some hostings require RewriteBase to be uncommented
# Example:
# Your store url is http://www.yourcompany.com/store/cart
# So "RewriteBase" should be:
# RewriteBase /store/cart
RewriteBase /shop


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !html
RewriteCond %{REQUEST_URI} !xml
RewriteCond %{REQUEST_URI} !ico
RewriteCond %{REQUEST_URI} !php
RewriteCond %{REQUEST_URI} !pdf
RewriteCond %{REQUEST_URI} !png
RewriteCond %{REQUEST_URI} !xls
RewriteCond %{REQUEST_URI} !doc
RewriteCond %{REQUEST_URI} !jpg
RewriteCond %{REQUEST_URI} !(.*)/$
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ http://newsteptech.com/$1/[L,R=301]

RewriteCond %{REQUEST_FILENAME} !\.(png|gif|ico|swf|jpe?g|js|css)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php?sef_rewrite=1 [L,QSA]

RewriteCond %{REQUEST_FILENAME} .*\/catalog\/.*
RewriteCond %{REQUEST_FILENAME} -d
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteRule . index.php?sef_rewrite=1 [L,QSA]

RewriteCond %{HTTP_HOST} ^www.(.*) [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,NC,L]  

</IfModule>
# redirect 301 /lien-he-1.html http://newsteptech.c...op/lien-he.html
# Use PHP53 as default
AddHandler application/x-httpd-php53 .php
<IfModule mod_suphp.c>
    suPHP_ConfigPath /opt/php53/lib
</IfModule>



 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 12091 posts

Posted 31 March 2017 - 11:56 PM #7

I'd get rid of all your rewritecond statements that have things like !html and the associated rewrite rule.  Not sure what you're trying to accomplish there.

 

Maybe use something like:

RewriteCond %{QUERY_STRING} ^(.*)dispatch=_no_page(.*)$
RewriteRule ^(.*)$ http://newsteptech.com[L,R=301] 

 

Might have to play with it...


EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 02 April 2017 - 07:17 AM #8

Not working :( :(

 

I'd get rid of all your rewritecond statements that have things like !html and the associated rewrite rule.  Not sure what you're trying to accomplish there.

 

Maybe use something like:

RewriteCond %{QUERY_STRING} ^(.*)dispatch=_no_page(.*)$
RewriteRule ^(.*)$ http://newsteptech.com[L,R=301] 

Might have to play with it...



 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 03 April 2017 - 02:55 PM #9

Anyone can help me :(



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3987 posts

Posted 03 April 2017 - 08:17 PM #10

I really don't understand all of the rewrites myself unless it has something to do with your main domain splitting to 3 different sites.?

 

I would probably try changing all the http to https.



 
  • trunglk
  • Junior Member
  • Trial users
  • Join Date: 22-Apr 11
  • 22 posts

Posted 07 April 2017 - 03:53 AM #11

I install my shop on subfolder http://mydomain.com/shop/and only my shop frontend error when run on https.