Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Images Not Displaying After Importing In Admin Panel Rate Topic   - - - - -

 
  • ferero
  • Advanced Member
  • Trial users
  • Join Date: 25-Apr 15
  • 87 posts

Posted 15 February 2017 - 03:59 AM #1

My website has been setup and running. However, we are having problems with images not displaying on the storefront. I can upload the images with no problem at all, but after uploading the images and viewing the product on the frontend, nothing appears. This happens every time I create a new product and upload images or even when I upload additional images to existing products on the site. 
 
Please note: the images folder and subdirectories all have permission 777 assigned to them.
 
Any ideas on how to fix this? 
Thanks


 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19976 posts

Posted 15 February 2017 - 06:41 AM #2

On the Update product page if you click on the image, original image should be displayed to you (nit thumbnail). Is it displayed correctly?


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • ferero
  • Advanced Member
  • Trial users
  • Join Date: 25-Apr 15
  • 87 posts

Posted 15 February 2017 - 09:19 AM #3

I don't know what you mean by "Update product page". There's no Update product page, only the actual product page. Yes, when I click on any broken image, it displays in full. 



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19976 posts

Posted 15 February 2017 - 02:33 PM #4

I don't know what you mean by "Update product page". There's no Update product page, only the actual product page. Yes, when I click on any broken image, it displays in full. 

 

I meant product page in the admin panel


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • ferero
  • Advanced Member
  • Trial users
  • Join Date: 25-Apr 15
  • 87 posts

Posted 15 February 2017 - 04:13 PM #5

original image appear when i click on it in admin panel. but that doesn't solve the problem.



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3870 posts

Posted 15 February 2017 - 06:41 PM #6

It sounds like the thumbnail isn't being created.?  See if the file exists in the thumbnail directory.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19976 posts

Posted 16 February 2017 - 07:09 AM #7

original image appear when i click on it in admin panel. but that doesn't solve the problem.

 

I asked it, because we should know if the original image is corrupted or thumbnails which are generated from this thumbnail.

 

Try to play with the image_resize_lib tweak in the config.local.php file. Try both variants (imagick and gd). After each change clear cache and thumbnails (&cc&ct)


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • ferero
  • Advanced Member
  • Trial users
  • Join Date: 25-Apr 15
  • 87 posts

Posted 16 February 2017 - 09:23 PM #8

Thanks for the responses thus far! 

 

I don't know exactly know what you mean by:

 

"Try to play with the image_resize_lib tweak in the config.local.php file. Try both variants (imagick and gd). After each change clear cache and thumbnails (&cc&ct)

 

 Maybe you can provide me with stepwise approach to solving this issue. It's frankly beyond me at this point. I have NO idea what to do. I'm no expert hence I need help!

 

Thanks



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19976 posts

Posted 17 February 2017 - 07:09 AM #9

Maybe you can provide me with stepwise approach to solving this issue. It's frankly beyond me at this point. I have NO idea what to do. I'm no expert hence I need help!

 

I am not sure if it solve the issue. It's just a hunch. If you are not familiar with tweaks, please contact CS-Cart support team.


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)