Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Error Changing To Default Theme Rate Topic   - - - - -

 
  • jeta
  • Advanced Member
  • Trial users
  • Join Date: 01-Apr 16
  • 146 posts

Posted 10 January 2017 - 12:47 PM #1

Hello!
 
I have tried to upload and install a new template in my store daily.al, but i have some problems with the instalation, i removed the theme and tried to change again to default theme but i can't an 404 error is shown and i can't understand why. The developers of the theme that i have purchased say that they need to have activated the default theme to procced with the installation of the new theme , can you please provide me some help with this issue? Why i am having troubles changing to default theme?


 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19379 posts

Posted 10 January 2017 - 02:08 PM #2

Try to remove the default theme from the design/themes directory. Then  go to Design -> Themes -> Browse all available themes and try to install this theme from repository


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • jeta
  • Advanced Member
  • Trial users
  • Join Date: 01-Apr 16
  • 146 posts

Posted 10 January 2017 - 03:13 PM #3

Try to remove the default theme from the design/themes directory. Then  go to Design -> Themes -> Browse all available themes and try to install this theme from repository

But if i try to delete it form themes, it won't be shown at browse all themes. I have tried to install the template from the repository and now i have the template of the default theme but the layout of the theme that i deleted. I am having such troubles just to change a theme, the develop team of the theme that i want to install and activate say to me that i need to have activated the default theme to make the new installation.



 
  • jeta
  • Advanced Member
  • Trial users
  • Join Date: 01-Apr 16
  • 146 posts

Posted 10 January 2017 - 03:39 PM #4

Try to remove the default theme from the design/themes directory. Then  go to Design -> Themes -> Browse all available themes and try to install this theme from repository

When i try to install as you suggested i click install in Design-->Themes-->Browse all avaiable the the installation begins but it closes after 2 sec and nothing happens. 



 
  • markhedley
  • Advanced Member
  • Trial users
  • Join Date: 19-Nov 16
  • 129 posts

Posted 11 January 2017 - 02:10 AM #5

When i try to install as you suggested i click install in Design-->Themes-->Browse all avaiable the the installation begins but it closes after 2 sec and nothing happens. 

Check the logs to see if there is any problem (Server and CS Cart). Also what mode is your server running? mod_php, fCGId or ?



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19379 posts

Posted 11 January 2017 - 07:19 AM #6

Check the logs to see if there is any problem (Server and CS Cart). Also what mode is your server running? mod_php, fCGId or ?

 

Agree, check error message in the server error logs


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • jeta
  • Advanced Member
  • Trial users
  • Join Date: 01-Apr 16
  • 146 posts

Posted 11 January 2017 - 09:29 AM #7

Hello!
 
This are the error i ma getting from the error log, it shows that i can't upload the template, can anyone give me an idea what is happening?? I will be very gratefull
 
[10-Jan-2017 14:14:59 Europe/Berlin] PHP Fatal error:  Uncaught  --> Smarty: Unable to load template tygh 'index.tpl' <-- 
  thrown in /home/globama3/public_html/daily/app/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 129
[10-Jan-2017 06:15:55 America/Denver] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/: cannot read file data: Is a directory in Unknown on line 0
[10-Jan-2017 14:15:55 Europe/Berlin] PHP Fatal error:  Uncaught  --> Smarty: Unable to load template tygh 'index.tpl' <-- 
  thrown in /home/globama3/public_html/daily/app/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 129
[10-Jan-2017 06:15:57 America/Denver] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/: cannot read file data: Is a directory in Unknown on line 0
[10-Jan-2017 14:15:57 Europe/Berlin] PHP Fatal error:  Uncaught  --> Smarty: Unable to load template tygh 'index.tpl' <-- 
  thrown in /home/globama3/public_html/daily/app/lib/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php on line 129
[10-Jan-2017 15:11:50 Europe/Berlin] PHP Notice: Undefined index: file in /home/globama3/public_html/daily/app/controllers/backend/templates.php on line 478
[10-Jan-2017 15:11:50 Europe/Berlin] PHP Notice: Undefined index: file_path in /home/globama3/public_html/daily/app/controllers/backend/templates.php on line 479
[10-Jan-2017 15:11:52 Europe/Berlin] PHP Notice: Undefined index: file_path in /home/globama3/public_html/daily/app/controllers/backend/templates.php on line 347
[10-Jan-2017 15:11:52 Europe/Berlin] PHP Notice: Undefined index: file in /home/globama3/public_html/daily/app/controllers/backend/templates.php on line 347


 
  • nagamahesh22
  • Advanced Member
  • Trial users
  • Join Date: 26-Mar 16
  • 50 posts

Posted 19 May 2017 - 06:22 AM #8

 

Error:- 

kramssmart.cscart_storage_data' doesn't exist (1146)SELECT `data` FROM cscart_storage_data WHERE `data_key` = 'store_mode' 

 

How to fix it this issue

 

 

 

 

kramssmart.cscart_storage_data' doesn't exist (1146)SELECT `data` FROM cscart_storage_data WHERE `data_key` = 'store_mode' 




 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3800 posts

Posted 19 May 2017 - 01:55 PM #9

If the table is missing, you need to add it.  The following query is default:

CREATE TABLE `cscart_storage_data` (
  `data_key` varchar(255) NOT NULL DEFAULT '',
  `data` mediumblob
) ENGINE=MyISAM DEFAULT CHARSET=utf8;


 
  • nagamahesh22
  • Advanced Member
  • Trial users
  • Join Date: 26-Mar 16
  • 50 posts

Posted 25 May 2017 - 10:10 AM #10

 

If the table is missing, you need to add it.  The following query is default:

CREATE TABLE `cscart_storage_data` (
  `data_key` varchar(255) NOT NULL DEFAULT '',
  `data` mediumblob
) ENGINE=MyISAM DEFAULT CHARSET=utf8;

 

Thank u and its working.



 
  • nagamahesh22
  • Advanced Member
  • Trial users
  • Join Date: 26-Mar 16
  • 50 posts

Posted 25 May 2017 - 10:18 AM #11

Hi 

 

I have one problem to run application in localhost. Actually, Run the application to redirect https url. How to overcome this problem in localhost. Please help me.

 

Regards,

Naga mahesh bondada,

maheshbondada2@gmail.com,

7893772765.