Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

4.4.1 Install Broken Rate Topic   - - - - -

 
  • MimiWatch
  • Member
  • Members
  • Join Date: 14-Jun 08
  • 137 posts

Posted 16 November 2016 - 06:11 PM #1

After clean install 4.4.1 version on localhost admin and front broken. 
 
Sample:
 
 
 

 

Which can be a problem?

 



 

Posted 16 November 2016 - 09:00 PM #2

Have same problem.

 

http://prntscr.com/d8678h



 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3809 posts

Posted 17 November 2016 - 06:48 AM #3

 

After clean install 4.4.1 version on localhost admin and front broken. 
 
Sample:
 
 
 
 
 
 

 

Which can be a problem?

 

 

 

Have same problem.

 

http://prntscr.com/d8678h

 

The problem requires examination on your servers. Please contact us via Customer Help Desk and provide temporary access to your server by clicking on the Add record  link on the Access information page of your Help Desk account so that we could examine the issue.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • martfox
  • Member
  • Authorized Reseller
  • Join Date: 15-Jan 10
  • 558 posts

Posted 17 November 2016 - 07:52 AM #4

Hi,

 

the "problem" is, that the browser does not request the CSS or JS files, therefore css or js are not loaded properly.

 

  1. do you have any browser addblocker installed/actvated? If yes, try to disable or uninstall it.
  2. check your web server and site error log - it should provide some info.
  3. the css/js could NOT be generated due file/directory permissions, insufficient memory, or max execution limit. Again, check your web server error log.
  4. view the source of your page and click the css links, if it is pointed correctly it should bring you to the css page.
  5. refresh the site in browser wit Ctrl+F5 combination
  6. your browser is not loading the css or js, which is hosted on another domain. Possible reasons could be due to the stylesheet domain being blocked or because your browser is failing to get DNS resolution for it.
  7. if installed on a live server you can checked it through a proxy service, like http://www.locabrowser.com/

Check these things above and see if you get some results.


CS-Cart with 1 Year FREE Web Hosting | CS-Cart optimized SSD Cloud VPS Servers from €10.00/month
.
VPS SSD Cloud from €10.00 *** Dedicated Servers *** CS-Cart Authorized Reseller and Web Hosting Provider


 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11422 posts

Posted 17 November 2016 - 08:00 AM #5

Or it could simply be a timestamp issue where the cached version in your browser is more recent than the timestamp in the archive. Clear your browser cache for your site.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • MimiWatch
  • Member
  • Members
  • Join Date: 14-Jun 08
  • 137 posts

Posted 17 November 2016 - 12:35 PM #6

Update: 

 

Testing in localhost (wampserver)

Same localhost, same configuration : 4.3.9 and 4.3.10 working, no problem. Only 4.4.1 broken

CSS and JS loaded

Error logs clean 

No Ad block etc, tested on more browser

 

Surce code (admin login):

http://pastebin.com/37Gscgyj  4.4.1

http://pastebin.com/ci6qz3cu  4.3.10

 



 
  • Darius
  • Douchebag
  • Members
  • Join Date: 20-Apr 08
  • 3309 posts

Posted 17 November 2016 - 12:43 PM #7

Maybe this

http://forum.cs-cart...or-cs-cart-441/



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19830 posts

Posted 17 November 2016 - 02:08 PM #8

Note that windows is not officially supported 

 

http://forum.cs-cart...on/#entry227879


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • Seonid
  • Member
  • Authorized Reseller
  • Join Date: 07-May 10
  • 207 posts

Posted 17 November 2016 - 03:59 PM #9

found the problem:

in file "app/functions/fn.common.php"

replace the line 5443:

$css_suffix = 'css' . DIRECTORY_SEPARATOR;

with

$css_suffix = 'css/';

 

that's it.


SEONID

Cs-cart Mobile skin (Iphone skin) | JS Banners Add-on

Specialized in:
CS-Cart custom design | Skin integration | Custom Add-ons | Custom Cs-cart development

Contact us here:
Contact

 
  • MimiWatch
  • Member
  • Members
  • Join Date: 14-Jun 08
  • 137 posts

Posted 18 November 2016 - 08:00 AM #10

found the problem:

in file "app/functions/fn.common.php"

replace the line 5443:

$css_suffix = 'css' . DIRECTORY_SEPARATOR;

with

$css_suffix = 'css/';

 

that's it.

 

Working! Thank you :)



 
  • martfox
  • Member
  • Authorized Reseller
  • Join Date: 15-Jan 10
  • 558 posts

Posted 18 November 2016 - 09:03 AM #11

found the problem:

in file "app/functions/fn.common.php"

replace the line 5443:

$css_suffix = 'css' . DIRECTORY_SEPARATOR;

with

$css_suffix = 'css/';

 

that's it.

 

Hi,

 

is this a bug? In the previous versions this line is missing there.


CS-Cart with 1 Year FREE Web Hosting | CS-Cart optimized SSD Cloud VPS Servers from €10.00/month
.
VPS SSD Cloud from €10.00 *** Dedicated Servers *** CS-Cart Authorized Reseller and Web Hosting Provider


 
  • ThomH
  • Senior Member
  • Members
  • Join Date: 20-Nov 07
  • 1572 posts

Posted 18 November 2016 - 09:58 AM #12

The official fix from IMAC:

http://forum.cs-cart...e-2#entry264293


WebGraphiq offers a wide range of professionally developed, ready to use CS-Cart add-ons to provide additional functionality and boost your sales. The oldest active CS-Cart add-on development team. -- Since 2006 --


CS-CART ADD-ONS | FREE QUOTE | CS-CART DEVELOPMENT | @webgraphiq


 
  • Seonid
  • Member
  • Authorized Reseller
  • Join Date: 07-May 10
  • 207 posts

Posted 18 November 2016 - 12:10 PM #13

this post is DELETED - not working :)

the problem is more complex, lots of files and lines are needed to be updated in order to work on all platforms...

The main problem with some php windows installations is:

file_exists('c:\somefile.txt') -> returns always true if the file exists

file_exists('c:/somefile.txt') -> returns false for most windows php installs (xampp, wamp, etc) even if the file exists

 

I use php-cgi with nginx on windows (for development) and the $css_suffix fix is working for me.

 

For who is not working, wait for the next CS-Cart version or install another php build.


SEONID

Cs-cart Mobile skin (Iphone skin) | JS Banners Add-on

Specialized in:
CS-Cart custom design | Skin integration | Custom Add-ons | Custom Cs-cart development

Contact us here:
Contact

 
  • Smich
  • Advanced Member
  • Members
  • Join Date: 13-Jan 12
  • 65 posts

Posted 29 November 2017 - 12:14 PM #14

An old thread,but replying here because we're currently upgrading after a delay and ran into problems with 4.4.1)

 

Note that windows is not officially supported 

 

http://forum.cs-cart...on/#entry227879

 

This is incorrect. As we noted in our reply, the only actual requirements were for specific versions of PHP and MySQL. Everything else was a "recommendation" only:-

 

"We recommend [my emphasis] a Unix-like operating system for your server, such as FreeBSD, Linux, or OS X. These systems are scalable, more secure, and offer better performance. [..] CS-Cart is compatible with almost every server that supports PHP and MySQL. However, we recommend [my emphasis again] Apache or Nginx as the most robust and stable servers for your web store."

 

This was the case when that comment was originally made (4.3.x IIRC), when 4.4.1 came out, and still applies to 4.6.x.

 

If Windows "isn't (officially) supported"- or at least can't be assumed to work- this should be stated explicitly. I appreciate that Apache, Linux et al are better choices (hence "recommended"), but that's not the same as a requirement.

 

I'm assuming the problem in this case was caused by a (lack of) testing issue.

 

Edit; at any rate, Martfox's solution appears to work. Thank you.