Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Our Brands Returns 404 Page Rate Topic   - - - - -

 
  • kevin13952
  • Member
  • Members
  • Join Date: 21-Nov 11
  • 33 posts

Posted 19 July 2016 - 12:34 PM #1

I deleted all products in my store and imported new products and their brands.

 

The variants of the Brand feature are showing all of my brands correctly in admin.

 

I've checked the feature ID and ensured that the quick menu link for brands is correct and matches the feature ID.

 

I've cleared my cache.

 

But when I click on the "Our brands" link on the homepage, it returns a 404 page not found error.

 

Any suggestions?



 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 19 July 2016 - 01:31 PM #2

I deleted all products in my store and imported new products and their brands.

 

The variants of the Brand feature are showing all of my brands correctly in admin.

 

I've checked the feature ID and ensured that the quick menu link for brands is correct and matches the feature ID.

 

I've cleared my cache.

 

But when I click on the "Our brands" link on the homepage, it returns a 404 page not found error.

 

Any suggestions?

 

Please check the link in the quick menu and make sure that the Brand filter ID is specified, not feature ID. Here is an example of the link:

 

product_features.view_all?filter_id=10

 

Also please make sure that the Brand feature value is selected for at least one product in the store.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation


 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19379 posts

Posted 19 July 2016 - 02:12 PM #3

FYI, filter ID can be found on the Products -> Filters page

 

http://prntscr.com/butf8m


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • kevin13952
  • Member
  • Members
  • Join Date: 21-Nov 11
  • 33 posts

Posted 25 July 2016 - 02:37 PM #4

I deleted all of the demo brands and have imported all of my tens of thousands of products.

 

But the brands page is returning as 404 page not found.

 

I have moused over the brands link in the features section and it shows the Feature>Brands to be 19

 

When I change my "Our Brands" menu link to "http://preppersite.n...l&filter_id=19"it returns page not found.

 

When I go into Filters section, it shows brands as #10

When I change my "Our Brands" menu link to "http://preppersite.n...l&filter_id=10"it returns page not found.

 

I have cleared the cache between these changes and nothing changes. The page always returns 404 page not found.

 

HELP!!!!!



 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3800 posts

Posted 25 July 2016 - 03:31 PM #5

http://preppersite.n...ll&filter_id=12



 
  • harsh
  • Member
  • Trial users
  • Join Date: 22-Sep 17
  • 18 posts

Posted 27 November 2017 - 09:48 AM #6

Hello all,

 

I deleted all products in my store and imported new products and their brands.

 

But when I click on the "Our brands" link on the homepage, it returns a 404 page not found error.

 

i have checked with the combinations by changing with the filter id but nothing seems to work 

 

Please suggest me with the solution

 

Thank you.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19379 posts

Posted 27 November 2017 - 12:55 PM #7

Please make sure that the Brands filter uses correct Feature after import


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • harsh
  • Member
  • Trial users
  • Join Date: 22-Sep 17
  • 18 posts

Posted 27 November 2017 - 01:37 PM #8

Please make sure that the Brands filter uses correct Feature after import

Hello,

 

Everything is correct from admin panel but i think the the  function

 

is not getting the variants value when i have gone through the code

 

When i Compared the code everything seems to be alright but dont know why it is not getting values 

 

and its getting 404 error please suggest me with solution .

 

Thank you.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19379 posts

Posted 28 November 2017 - 05:38 AM #9

PM me temporary access, we will check


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • CS-Cart team
  • CS-Cart support team
  • Moderators
  • Join Date: 04-Apr 11
  • 3808 posts

Posted 28 November 2017 - 06:30 AM #10

Are there any products with brands in your store?

 

Hello,

 

Everything is correct from admin panel but i think the the  function

 

is not getting the variants value when i have gone through the code

 

When i Compared the code everything seems to be alright but dont know why it is not getting values 

 

and its getting 404 error please suggest me with solution .

 

Thank you.


Sincerely yours, CS-Cart Support Team

 

User guide       |  Developer documentation  |  Core API documentation