Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Проблемы После Обновления Версии 4.3.4. На 4.3.5 Rate Topic   - - - - -

 
  • Maesstro
  • Newbie
  • Trial users
  • Join Date: 26-Dec 15
  • 1 posts

Posted 26 December 2015 - 09:33 PM #1

Добрый день! После попытки обновиться на версию 4.3.5 Яндекс-Маркет выдал сообщение об ошибке в прайс-листе. 

 

Вот сообщение от ЯМ:

 

Фатальная ошибка: Ошибка парсинга XML: Error parsing XML feed: EntityRef: expecting ';' (    <category id="268" parentId="288">Clever&Clean ) (строка 20, столбец 51)

 

Открываю прайс в браузере, вижу:

 

Ошибка синтаксического анализа XML: некорректно
Адрес: http://iq-technika.r...dex_market.view
Строка 20, символ 51:    <category id="268" parentId="288">Clever&Clean</category>

Разбираться было некогда, откатился обратно на старую версию. Как это лечить - не знаю ((

После чего обнаружил, что перестала работать корзина. Окно не открывается, товары не добавляются.  То же самое наблюдается при откатах на более старые версии (бэкапы) с хостинга, хотя до этого они абсолютно точно работали, товары добавлялись в корзину.

Прочитал форумы - нашел сообщение, что в каких-то версиях причина была в модуле Яндекс-Метрика. Отключил этот модуль - и корзина начала работать.

Однако, сама ситуация настораживает. Что случилось с корзиной, почему она перестала работать после отката на старую версию?  В версии 4.3.5. корзина работает нормально, но вот проблемы с прайсом...

Что происходит с прайс-листом после обновления версии?  Что происходит с корзиной при откате?

Спасибо!



 
  • atamanko
  • Member
  • Members
  • Join Date: 31-Jan 15
  • 35 posts

Posted 30 January 2016 - 12:38 PM #2

Была та же проблема, заменил все амперсанды (&) на and и все заработало.