Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

How To Get Redis Working On 4.2? Rate Topic   - - - - -

 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1138 posts

Posted 02 September 2015 - 03:21 PM #1

I want to activate redis to speed up my 4.2 installation. Redis is installed on the server. When I follow the instruction in the KB then I am getting a whitepage which keeps loading forever. There are no php errors. Nothing in the browser console.

Does anyone know how to get thsi working?



 
  • gleb.goncharov
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 04-Oct 13
  • 351 posts

Posted 05 September 2015 - 06:28 PM #2

I want to activate redis to speed up my 4.2 installation. Redis is installed on the server. When I follow the instruction in the KB then I am getting a whitepage which keeps loading forever. There are no php errors. Nothing in the browser console.

Does anyone know how to get thsi working?

 

Have you tried to look at the server error log?



 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1138 posts

Posted 06 September 2015 - 12:34 AM #3

Yes, there are no errors.



 
  • kogi
  • Senior Member
  • Members
  • Join Date: 16-Aug 07
  • 620 posts

Posted 06 September 2015 - 01:02 AM #4

Yeah, I too have had no luck in getting redis to work in 4.2.4, gave up and stuck with sqlite


find / -type f -name '*.base' -exec chown kogi.kogi {} \;

 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1138 posts

Posted 06 September 2015 - 08:53 PM #5

@imac can you let us know about this cs-cart function?



 
  • imac
  • Head of Product
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2074 posts

Posted 07 September 2015 - 07:25 AM #6

Yeah, I too have had no luck in getting redis to work in 4.2.4, gave up and stuck with sqlite

 

@imac can you let us know about this cs-cart function?

 

Installed 424 on Digital Ocean using @goncharov ansible deployer https://github.com/g...cscart-deployer- Redis works fine.

I suppose the problem in Redis configuration at your server. First of all find error in the logs. Because empty page means there is some server error thus you can log it.

 

To be honest during testing I did not see much increase in performance with Redis, i.e. its about 1-3%.


Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • P-Pharma
  • Junior Member
  • Members
  • Join Date: 30-Jun 10
  • 1138 posts

Posted 07 September 2015 - 10:35 AM #7

imac: Besides reddis, are there other recommendations to speed up 4.2?

Is there an english version of the reddis deployer?