Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

CS-Cart & Multi-Vendor 4.3.1 Released Rate Topic   * * * * * 1 votes

 
  • San
  • Member
  • Members
  • Join Date: 04-Feb 10
  • 208 posts

Posted 20 May 2015 - 07:37 PM #141

had this error after upgrade.

Error occurred: post upgradeDuplicate entry '79-fr' for key 'PRIMARY' (1062): INSERT INTO cscart_bm_locations_descriptions (`lang_code`, `name`, `title`, `meta_description`, `meta_keywords`, `location_id`)

VALUES ('fr', 'Search results', '', '', '', 79)

seemed to work ok but I have restored it back until I know what thisa error means. Any ideas?

 
  • kogi
  • Senior Member
  • Members
  • Join Date: 16-Aug 07
  • 639 posts

Posted 20 May 2015 - 09:47 PM #142

The whole upgrade process is not very business friendly.


It seems weird to me to upgrade by php, I would much prefer a console command line option. Where I imagine it would be just an untar and mysql script.
find / -type f -name '*.base' -exec chown kogi.kogi {} \;

 
  • alssafeer
  • Advanced Member
  • Members
  • Join Date: 03-Dec 11
  • 77 posts

Posted 21 May 2015 - 12:58 AM #143

searchanise not working in 4.3.1 !

 
  • bytraper
  • Member
  • Members
  • Join Date: 27-Oct 09
  • 151 posts

Posted 21 May 2015 - 02:45 AM #144

Hey guys,
we did the upgrade from 4.2.4 to 4.3.1 yesterday on our completely unmodified store and it was mostly painless. The only error we got during the entire process was:
Importing data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Notice: Undefined index: LanguageName in /chroot/home/motiondy/motiondynamics.com.au/html/app/Tygh/Languages/Po.php on line 46

Error PO-file contains syntax errors or incorrect structure. Please re-check it and upload again.

The upgrade still went ahead and we haven't seen any ill effects from the error, but I would be happier knowing what it actually was. But, the upgrade was relatively painless.

I'd like to say that everything that worked perfectly before the upgrade still worked perfectly after the upgrade.

Unfortunately, a lot of thing's don't actually work the way they are supposed to in 4.3.1 but its only small things that are inconvenient, there's nothing that's cart breaking that we haven't been able to work around.

Now we are stuck waiting for CS-Cart to get back to us to fix the problems that have come from the 4.3.1 upgrade. I hope it wont take too long, but we posted yesterday and haven't heard a single thing back and that's usually not a good sign.

I wish you all good luck with your upgrades, ours went surprisingly better than previous upgrade efforts.

 
  • jimmyod
  • Senior Member
  • Members
  • Join Date: 24-Apr 12
  • 459 posts

Posted 21 May 2015 - 01:29 PM #145

I tried update today and when I hit "Install", a blank white screen appeared.
Past experience taught me to back up everything, which I did.
This time nothing went wrong, except absolutely nothing happened.
I went back to admin panel without a problem..

It seams that the package "uc.tgz 9,976 kb" has been uploaded to my server. But I guess it just isn't being unpacked & installed. Should this have execute permissions?

I can not install again. I do not have upgrade available anymore. How can I re install this again?

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 21 May 2015 - 02:06 PM #146

Guys,

Just to let you know, architects team helps tech support, and we do some upgrades and investigate the issues.
You can post your support ticket ids here.

Please note: That we do not give away upgrades at the moment, we will add fix for restore function.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • CutRiteFX
  • Senior Member
  • Members
  • Join Date: 02-Jun 08
  • 434 posts

Posted 21 May 2015 - 03:12 PM #147

Support ticket ID: #101297793 Upgrade shows blank page and does not install.

 
  • jimmyod
  • Senior Member
  • Members
  • Join Date: 24-Apr 12
  • 459 posts

Posted 21 May 2015 - 03:19 PM #148

Support ticket ID: #101299671

 
  • CutRiteFX
  • Senior Member
  • Members
  • Join Date: 02-Jun 08
  • 434 posts

Posted 22 May 2015 - 03:31 PM #149

So I get an email today from my store saying that my store has just been upgraded. I login to check to see what is going on. It was still at 4.2.4. I checked the logs and seems it may have been someone from cscart logged in as me. I did give them access in my ticket.

I checked the helpdesk ticket and this is what they said
We increased the value of the memory_limit directive on your server, so you should be able to upgrade your store to the latest version.

I did the upgrade and it worked like a champ.

 
  • Darius
  • Douchebag
  • Members
  • Join Date: 20-Apr 08
  • 3557 posts

Posted 25 May 2015 - 02:19 PM #150

So many bug while in upgrade reported, is current version suitable for live site when fresh installed? Also would be helpful to know when 4.3.2 is coming?

 
  • cncinc
  • Senior Member
  • Members
  • Join Date: 23-Aug 12
  • 165 posts

Posted 26 May 2015 - 08:02 AM #151

shipping mehtod happen CSRF ATTACK. because a lot of shipping country setting of EMS sort of it..

so i setting

1-------max_input_vars PHP directive to 10000
2------pcre.backtrack_limit to 10000000
3------enable the CSRF tweak

1~~2 php.ini <----setting
3 <------------csrf tweak enable where i can setting?

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 26 May 2015 - 09:15 AM #152

shipping mehtod happen CSRF ATTACK. because a lot of shipping country setting of EMS sort of it..

so i setting

1-------max_input_vars PHP directive to 10000
2------pcre.backtrack_limit to 10000000
3------enable the CSRF tweak

1~~2 php.ini <----setting
3 <------------csrf tweak enable where i can setting?


You can find it in config.local.php file. We call "tweaks" the $config['tweaks'] array.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 26 May 2015 - 09:19 AM #153

So many bug while in upgrade reported, is current version suitable for live site when fresh installed? Also would be helpful to know when 4.3.2 is coming?


Darius,

4.3.2 will be this or next week.

We found one major bug at the moment - some hooks may not work at certain circumstances - can be reproduced with some 3-party add-ons. More details can be found here: http://forum.cs-cart...direction-loop/
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • UrKo
  • Junior Member
  • Members
  • Join Date: 08-Dec 06
  • 162 posts

Posted 26 May 2015 - 11:49 AM #154

Ok, Im confused. Should I upgrade from 4.2.4 to 4.3.1 or should I wait for 4.3.2??
So many problems here that im not sure.
UrKo

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 26 May 2015 - 12:26 PM #155

I would recommend to wait for 4.3.2.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • Joachim
  • Advanced Member
  • Members
  • Join Date: 05-Oct 11
  • 69 posts

Posted 26 May 2015 - 05:17 PM #156

I did the installation 4.3.1 the usual way. No problems at all and no error messages. :)
<p>4.4.2 Ultimate (6 storefronts)

 
  • remoteone
  • Member
  • Members
  • Join Date: 06-Oct 09
  • 779 posts

Posted 28 May 2015 - 03:24 AM #157

I would recommend to wait for 4.3.2.

I wish I'd read that suggestion first. I wanted desparately to fix the Product Positions Bug so was hoping this upgrade would work.
I did an upgrade to 4.3.1 today and got:

ErrorPO-file contains syntax errors or incorrect structure. Please re-check it and upload again.


Q1 How to fix this?
Q2 Does this mean the update did not complete?
The ?version reports as 4.3.1

So the big question is...
Q3. Should I revert back to 4.2.4 until v4.3.2 is released, or should I try to fix the cause of the error and complete the 4.3.1 upgrade.?

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 29 May 2015 - 11:59 AM #158

Guys,

looks like we found and fixed all issues with upgrade to v4.3.1
So now you can upgrade. Please note that in case you have some problems with add-on you should apply this fix: http://forum.cs-cart...don-and-others/

4.3.2 is planned for next week.
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug

 
  • mokeshop
  • Senior Member
  • Members
  • Join Date: 27-Jul 12
  • 1016 posts

Posted 29 May 2015 - 12:23 PM #159

Guys,

looks like we found and fixed all issues with upgrade to v4.3.1
So now you can upgrade. Please note that in case you have some problems with add-on you should apply this fix: http://forum.cs-cart...don-and-others/

4.3.2 is planned for next week.

great news... please don't forget that the 4.3.1 was distributed on april 29 so the new update should cover also this distribution.

best wishes dzemal

 
  • imac
  • CEO
  • CS-Cart Architects
  • Join Date: 22-Nov 05
  • 2077 posts

Posted 29 May 2015 - 12:27 PM #160

great news... please don't forget that the 4.3.1 was distributed on april 29 so the new update should cover also this distribution.

best wishes dzemal


what do you mean, demeldoo?
Ilya Makarov,
CS-Cart Architect Team
Suggest and vote for new features | Report a bug