Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Janrain Social Login Not Working With Cscart 4.2.4 Rate Topic   - - - - -

 
  • thomas
  • Advanced Member
  • Members
  • Join Date: 19-Nov 12
  • 83 posts

Posted 07 April 2015 - 01:05 PM #1

Hi there,

I am troubling an issue with Janrain, add social login features, addons. I have recently upgrade my cscart store from CS-Cart: version 3.0.4 ULTIMATE to CS-Cart 4.2.4. The issue is the janrain modal popup not opening when I click Janrain social login link of my site. I have a setup in janrain account and have API Key and Domain.

The janrain social login was working on my previous site but it do not work with cscart version 4.2.4. I have also set up my old backup site into the same server under a subfolder, and use the same api key and domain and check it works with it. I am really confused why its not working on my new cscart version 4.2.4.

Is there anyone who can assist me why its happening?



Thanks,
Thomas
Cheers!
Thomas

 
  • CS-Market
  • Senior Member
  • Authorized Reseller
  • Join Date: 06-Mar 13
  • 676 posts

Posted 07 April 2015 - 01:41 PM #2

Hello Thomas,

Try to use the "Hybrid auth" add-on instead of Janrain.

Sincerely yours,
CS-Market.

GET A FREE QUOTE  │  CS-Cart add-ons   │   CS-Cart custom development   │  CS-Cart design integration  │  CS-Cart license

Сертифицированный разработчик на CS-Cart Русская Версия. More than 5 years experience in CS-Cart development.


 
  • thomas
  • Advanced Member
  • Members
  • Join Date: 19-Nov 12
  • 83 posts

Posted 08 April 2015 - 07:16 AM #3

Hi CS-Market,

Thanks for your quick reply.
Cheers!
Thomas

 

Posted 09 June 2015 - 01:13 PM #4

Dear I try to use hybrid_auth for facebook and this message is appear :
Invalid Scopes: read_friendlists. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.f...gin/permissions
How can I fix that?

 

Posted 09 June 2015 - 01:14 PM #5

Dear I try to use hybrid auth for facebook and this message is appear :
Invalid Scopes: read_friendlists. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.f...gin/permissions
How can I fix that?

 

Posted 09 June 2015 - 01:16 PM #6

Dear I try to use "Hybrid auth" add-on Invalid Scopes: read_friendlists. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.f...gin/permissions[/size][/font]
How can I fix that?

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19794 posts

Posted 10 June 2015 - 10:25 AM #7

Dear I try to use "Hybrid auth" add-on Invalid Scopes: read_friendlists. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.f...gin/permissions[/size][/font]
How can I fix that?


Please check:

http://forum.cs-cart...4-social-login/

GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.