Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

How To Prevent From Sending Email When An Order Placed? Rate Topic   * * * * * 1 votes

 
  • ooaykac
  • Senior Member
  • Members
  • Join Date: 22-Nov 12
  • 297 posts

Posted 05 February 2015 - 07:41 AM #1

I use the code below to save orders remotely in my addon :
list($order_id, $process_payment) = fn_place_order($cart, $auth, 'save')

How to prevent from sending email to the customer when an order placed remotely?

Note: I don't want to change default settings of OPEN status.

 
  • Hungryweb
  • Senior Member
  • Authorized Reseller
  • Join Date: 10-Feb 12
  • 1249 posts

Posted 05 February 2015 - 08:02 AM #2

The solution is more simple ;)

1. Please go to Administration > Order Statuses
Posted Image

2. Edit Open status and uncheck Notify customer
Posted Image

PS: If this helps you please Vote this post ;)

Regards,

---
Valentin
part of hungryweb.net

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19851 posts

Posted 05 February 2015 - 09:13 AM #3

Use the get_notification_rules hook in the fn_get_notification_rules function (app/functions/fn.common.php)

GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • ooaykac
  • Senior Member
  • Members
  • Join Date: 22-Nov 12
  • 297 posts

Posted 06 February 2015 - 08:23 AM #4

Thanks to all.

 
  • cakethings
  • Member
  • Trial users
  • Join Date: 15-Aug 11
  • 29 posts

Posted 08 January 2017 - 03:15 PM #5

What happen to Notify Customer and Notify Order Department. I no longer see then in

4.4.2.SP2

 

Thanks

Mark



 
  • BarryH
  • Senior Member
  • Members
  • Join Date: 03-Sep 07
  • 1459 posts

Posted 08 January 2017 - 03:29 PM #6

Hi

 

I made same mistake, if you have email editor active they don't show and you manage in the editor.

Barry


BarryH

 

CS-Cart v4.4.3 (Plus one being developed v4.5.2 SP2)
UK User


 
  • cakethings
  • Member
  • Trial users
  • Join Date: 15-Aug 11
  • 29 posts

Posted 22 January 2017 - 12:06 PM #7

OK I have disabled

Order notification: Default template for a new order status

and

 
I still get an email for open and paid, All I want is paid. I cannot seem to find the answer


 
  • johnbol1
  • Never Re
  • Members
  • Join Date: 23-Feb 10
  • 4673 posts

Posted 22 January 2017 - 12:15 PM #8

go into the order status "open" and remove the check box that says email


Custom printed hi visibility clothing sale the UK's online hivis safety shop
v4.5.2


 
  • The Tool
  • Been Here Way Too Long Member
  • Members
  • Join Date: 30-Mar 07
  • 3849 posts

Posted 22 January 2017 - 04:48 PM #9

OK I have disabled
Order notification: Default template for a new order status[/url]
and
Order notification: Open[/url]
 
I still get an email for open and paid, All I want is paid. I cannot seem to find the answer

 
 
I would also advise removing the links in your post.



 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19851 posts

Posted 23 January 2017 - 07:48 AM #10

 

OK I have disabled

Order notification: Default template for a new order status

and

Order notification: Open
 
I still get an email for open and paid, All I want is paid. I cannot seem to find the answer

 

 

It looks like a bug. Please post it to the bug tracker


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.