Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Default Responsive Theme Install Less Error Rate Topic   - - - - -

 
  • e236
  • Newbie
  • Members
  • Join Date: 06-Jan 15
  • 8 posts

Posted 31 January 2015 - 11:27 PM #1

Trying to install the default responsive theme that comes with CS Cart v4.2.4 results in a broken homepage due to the error below with the /public_html/design/themes/responsive/css/styles.less style sheet. Clearing the cache via the admin panel and FTP doesn't fix it. Adding a color to the line results in additional error after error found with any line that defines lighten or darken for color or background. This seems to be a common issue but couldn't find the fix using a google or forums search so any help would be really appreciated.


LESS expected color value: failed at `color: darken(@links, 10%);` line: 52
 
    .transition(all 150ms);
}
a:hover {
    color: darken(@links, 10%);
}
ul {
    padding: 0;
    margin: 0;


 
  • e236
  • Newbie
  • Members
  • Join Date: 06-Jan 15
  • 8 posts

Posted 03 February 2015 - 08:08 PM #2

Bump. Anyone have the fix for this issue?

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19044 posts

Posted 04 February 2015 - 08:14 AM #3

Please contact CS-Cart support team with this issue. We have never faced such issue.

GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • eweig
  • Member
  • Trial users
  • Join Date: 30-Jan 18
  • 42 posts

Posted 31 December 2018 - 08:30 PM #4

Was a solution ever given for this issue?   I'm having the same message after upgrading my version.



 
  • poppedweb
  • Authorized Reseller
  • Members
  • Join Date: 02-Aug 16
  • 479 posts

Posted 31 December 2018 - 09:26 PM #5

Try adding the following to the beginning of the file, if that works, you should edit the color code accordingly:

 

@links: #111;


PoppedWeb | sales@poppedweb.com | https://poppedweb.com
TurnKey Website Design | Add-Ons | Performance Audits | Dedicated Server Management
24/7 Support | Response within an hour (during working hours).

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19044 posts

Posted 04 January 2019 - 06:55 AM #6

Try to switch used style or make sure that the following file exists, not empty and has definition for the @links variable

 

design/themes/THEME/styles/data/USED_STYLE.less

 

http://prntscr.com/m2vd3i


GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.