Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Curl & Godaddy Rate Topic   - - - - -

 

Posted 24 May 2006 - 04:54 PM #1

//curl_setopt ($ch, CURLOPT_PROXY, 'myproxy.host.local:3128');
//curl_setopt ($ch, CURLOPT_PROXYUSERPWD, 'username:password');

I know the first line has to be
//curl_setopt ($ch, CURLOPT_PROXY, 'http://64.202.165.130:3128');

but I have no idea where to find my username and password for this? Anyone use Godaddy for their host and run into this problem?

 
  • susio1
  • Junior Member
  • Members
  • Join Date: 17-May 06
  • 7 posts

Posted 24 May 2006 - 07:43 PM #2

Did you try using your godaddy account username and password?

 

Posted 24 May 2006 - 08:45 PM #3

I have one for the master godaddy which is a number and password, another for the ftp login and pass....and I think another for the hosting cpanel login and pass....

 

Posted 26 May 2006 - 07:20 AM #4

Apparently the username and password wasn't an issue, just having the correct proxy info in there. Good to know.

 
  • Quicktune
  • Member
  • Members
  • Join Date: 10-May 06
  • 31 posts

Posted 09 January 2007 - 06:25 PM #5

I found the exact information that fixed my problem with the help of compernicus! (thanks! :oD )

For SSL I have Godaddy/Starlink, and I found that I had to add some curl proxy code, but I'm not sure where to add it. Do you happen to know if this is the correct code?

curl_setopt ($ch, CURLOPT_HTTPPROXYTUNNEL, TRUE);
curl_setopt ($ch, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
curl_setopt ($ch, CURLOPT_PROXY, "http://64.202.165.130:3128");
curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, FALSE);

And do I add this code into authorizeaim_net.php ? I tried and it still hangs at checkout, but now the orders show up in the admin side as 'open', but I don't see any errors.


Well it sounds like you at least found some important information. If I had known you were with Godaddy, I would have definitely guessed they had some special settings. I have heard of alot of people having problems getting things to work with them.

I would guess that the additional CURL settings need to go into the core\https.php file. There are several curl_setopt commands in that file already. In my file, they start right after line 79, where you see this:

$ch = curl_init();

You should be able to add your commands after that line. You should make sure that if the command already exists, however, that you change the setting instead of just adding it, otherwise, you may run into conflicts. Good luck!


I found that a line was commented out for the proxy address and uncommented it out and placed the correct godaddy proxy address in, and bam, great results!

From line 80:

//curl_setopt ($ch, CURLOPT_PROXY, 'myproxy.host.local:3128');

To:

curl_setopt ($ch, CURLOPT_PROXY, 'http://64.202.165.130:3128');
RedHat EnterPrise Linux Server
MYSQL 4.1
PHP Version 4.3.11
SSL Certification 256-bit Data Encryption
100GB
I ♥ CS-CART! :D

 
  • thenutrishop
  • Junior Member
  • Members
  • Join Date: 05-Aug 07
  • 23 posts

Posted 07 August 2007 - 02:01 AM #6

http://help.godaddy....?article_id=289