Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Upgrading From 4.2.1 To 4.2.2. Problem Rate Topic   - - - - -

 
  • doanky
  • Newbie
  • Members
  • Join Date: 04-Sep 12
  • 11 posts

Posted 30 September 2014 - 03:41 PM #21

Please help me,

I have a problem when update from 4.2.1 to 4.2.2 with the addon_lists.tpl (can not write), but the update was successfully.

Now, in admin page, there are some blank pages such as.
:: Manager Add ons
:: Payment Methods

How can I fix this problem. Thank you a lot.

Cheers,

 

Posted 15 October 2014 - 08:12 PM #22

We also had a problem with our install. We get this error:

Parse error: syntax error, unexpected $end in /data/3/2/81/71/2733234/user/3003717/htdocs/cs4/config.local.php on line 149

Line 149 in our config.local.php reads:

define('DEVELOPMENT', true);

I got this error code after the update failed and used their provided link as a
restore point.

I also get an access denied line during the file restoring.

Any insight would be awesome!!!

Thanks!

VH

 
  • johnbol1
  • Never Re
  • Members
  • Join Date: 23-Feb 10
  • 4704 posts

Posted 15 October 2014 - 08:18 PM #23

Did you add define('DEVELOPMENT', true); into config.local.php at some point to troubleshoot error messages, its usually not there.
try removing it and see what you get.

John

Custom printed hi visibility clothing sale the UK's online hivis safety shop
v4.5.2


 
  • zeero6
  • Senior Member
  • Members
  • Join Date: 25-Jan 07
  • 649 posts

Posted 22 October 2014 - 02:32 PM #24

This is still happening with upgrading from 4.2.2 to 4.2.3. I removed that code and still happens now with or without. Cleared cache also. Any idea? I do have a ticket with CSCart

Version 4.9.3 SP1


 
  • HappyPig0
  • Member
  • Members
  • Join Date: 18-Sep 14
  • 36 posts

Posted 23 October 2014 - 09:32 AM #25

I could cry! I up-graded, all seemed good.... website still live and looking sweet.
I then tried out the visual editor for one of the new themes I activated which again went live simply. However, visual editor when clicked says "Sorry, service temporarily unavailable" . I reverted back to my original theme, all good and live on the website again.

I then installed call return addon and my website now says the same "Sorry, service temporarily unavailable". Deactivated the Haddon but I still have no live website, only a red badge service unavailable message.

Have no idea what to do or check or deactivate or even activate. Long shot, but does anyone have any pointers for me? Thank you.

 
  • HappyPig0
  • Member
  • Members
  • Join Date: 18-Sep 14
  • 36 posts

Posted 23 October 2014 - 09:38 AM #26

PS... meant to add..... website went down when I tried to login on my website to make a test purchase.... My admin is working fine and my other non cs-cart websites all running off the same server are active.

Back again: Discovered my website http://www.store.wholesaleid.co.uk/ is live via chrome.... but I can't access it via safari. Maybe the challenge is local with Safari!

 
  • HappyPig0
  • Member
  • Members
  • Join Date: 18-Sep 14
  • 36 posts

Posted 23 October 2014 - 10:06 AM #27

Well I stumped! I rebooted my iMac, cleared cache and I still can't load my website in Safari. Chrome is fine. Safari opined and iPhone and mac mini all access my site. So, the site is live, I just have a local Safari issue to deal with. Any ideas?

Visual editor via admin on chrome still gives me a "page saying service temporairly unavailable, as with edit content onsite.

Up-date: Cleared history an cache in Safari for past hour.... website loads again! Weird, never had that before, will delete the login I used for test orders and set up another. Just the Visual editor and edit content onsite to sort out. Guess that's a support request direct to cs-cart.

Sorry to anyone following this threat... or maybe I have been entertaining!

 
  • tbirnseth
  • CS Cart Expert
  • Authorized Reseller
  • Join Date: 08-Nov 08
  • 11443 posts

Posted 23 October 2014 - 09:49 PM #28

You need to add
define('DEVELOPMENT', true);
to your config.local.php file temporarily.
This will show you the DB error that is causing the Service Unavailable page.
Fix the error and you'll be on your way.

EZ Merchant Solutions: Custom (USA based) B2B Development, Consulting, Development and Special Projects (get a quote here).
Commercial addons, payment methods and modifications to meet your business and operations needs.


 
  • UrKo
  • Junior Member
  • Members
  • Join Date: 08-Dec 06
  • 161 posts

Posted 24 October 2014 - 05:29 AM #29

So, I just upgraded to 4.2.3., everything is ok, but had to comment out same thing as i did when upgrading to 4.2.2...
When will this be fixed?
UrKo

 
  • HappyPig0
  • Member
  • Members
  • Join Date: 18-Sep 14
  • 36 posts

Posted 24 October 2014 - 05:58 AM #30

Wishing I hadn't done that now.... I added the code to line 24, just guess, didn't know where else.... website now just blank white page. I went back to config.local.php and removed it, touched nothing else..... but still a white blank page for a website.Yikes!

Can't access admin page either, that just white also.

 
  • HappyPig0
  • Member
  • Members
  • Join Date: 18-Sep 14
  • 36 posts

Posted 24 October 2014 - 07:21 AM #31

got it back - will leave Cs-Cart support team to handle the issues.... quite a shopping list actually!

 

Posted 03 November 2014 - 03:59 AM #32

I am waiting for SCART support to answer if that is he correct location and code

 
  • CartBooster
  • Senior Member
  • Members
  • Join Date: 25-Jun 06
  • 246 posts

Posted 16 August 2015 - 02:53 PM #33

Just had the same issue

I added an additional " } " character to the end of the file and refreshed the page and all was good for me

www.cartbooster.ie