Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Php 5.5 Rate Topic   - - - - -

 
  • gabbo
  • Junior Member
  • Trial users
  • Join Date: 04-May 11
  • 92 posts

Posted 10 July 2014 - 04:59 AM #1

Does cs 4.1.5 (4.2.*) work with php 5.5 ?

 
  • galtinbaeva
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 06-Dec 13
  • 3376 posts

Posted 10 July 2014 - 06:06 AM #2

Hello.

Thank you for the message.

The recommended php versions are 5.3 and 5.4, so one of those would be a safer choice. But as far as I know, there is quite a bit of CS-Cart users who use php 5.5 successfully.

Simtech Development | sales@simtechdev.com | www.simtechdev.com
CERTIFIED CS-CART PARTNER | LICENSES | DEVELOPMENT | ADD-ONS | DESIGN | UPGRADE

Google Analytics Enhanced Ecommerce - get advanced ecommerce analytics


 

Posted 22 October 2014 - 09:57 PM #3

I tried to upgrade my php version to 5.5 while using CS-CART: version 2.1.4 PROFESSIONAL and I get the following error displayed on the top of the homepage

Strict Standards: Declaration of Templater::display() should be compatible with Smarty::display($resource_name, $cache_id = NULL, $compile_id = NULL) in /homepages/5/d11254627/htdocs/mywebsite.com/core/class.templater.php on line 28

Is there a way to fix this issue without having to upgrade the whole cs-cart package?
Is that the only error for using php 5.5 and cs-cart 2.1.4 or there may be others that will create even more problems to the store?

I updated to php 5.5 and another store I have that is using CS-CART: version 2.2.5 PROFESSIONAL is not showing that same error...

Any suggestions?

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 19851 posts

Posted 23 October 2014 - 08:19 AM #4

I tried to upgrade my php version to 5.5 while using CS-CART: version 2.1.4 PROFESSIONAL and I get the following error displayed on the top of the homepage

Strict Standards: Declaration of Templater::display() should be compatible with Smarty::display($resource_name, $cache_id = NULL, $compile_id = NULL) in /homepages/5/d11254627/htdocs/mywebsite.com/core/class.templater.php on line 28

Is there a way to fix this issue without having to upgrade the whole cs-cart package?
Is that the only error for using php 5.5 and cs-cart 2.1.4 or there may be others that will create even more problems to the store?

I updated to php 5.5 and another store I have that is using CS-CART: version 2.2.5 PROFESSIONAL is not showing that same error...

Any suggestions?


Try the following solution:

https://help.1and1.c...le-a614325.html

GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    CS-Cart RU                         24500 руб.
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      CS-Cart RU + UniTheme    36000 руб.


 
  • dataspotgr
  • Member
  • Authorized Reseller
  • Join Date: 04-Sep 13
  • 42 posts

Posted 13 January 2016 - 02:35 PM #5

Hello all,

 

this issue can be solved if you make this change in your config.local.php file:

 

Old code:

error_reporting(E_ALL ^ E_NOTICE);
if (version_compare(PHP_VERSION, '5.3.0', '>=')) {
    error_reporting(error_reporting() & ~E_DEPRECATED & ~E_STRICT);
}

 

New code:

error_reporting(E_ALL ^ E_NOTICE);
if (version_compare(PHP_VERSION, '5.3.0', '>=')) {
error_reporting(error_reporting() & ~(E_DEPRECATED | E_STRICT));
}

 

in the beginning of the file...

 

Although if you have PHP version 5.5.x you will see some Warning messages at the categories products page.. or even in a specific product page..does not even load the page, probably because of timeout... 

 

Does anyone has this problem, too?

The version of this website is 2.2.5

 

 



 
  • dataspotgr
  • Member
  • Authorized Reseller
  • Join Date: 04-Sep 13
  • 42 posts

Posted 14 January 2016 - 02:20 PM #6

Hello all again,

 

I just read here in the forum another topic that said

 

"I should inform you that, unfortunately, PHP 5.4 is not supported by CS-Cart 2 as far as Smarty version 2.6.18 is used in it, which is not compatible with PHP 5.4. A lot of different problems may occur, so we recommend you to downgrade your PHP version to 5.3.x. or upgrade your store system to the latest version. CS-Cart 4.0.x/4.1.x supports PHP version 5.4."

 

here is the link:

http://forum.cs-cart...m-52-need-help/

 

So I guess, version 2.x.x is not supported via PHP 5.4