Jump to content

  • You cannot start a new topic
  • You cannot reply to this topic

Cs-Cart 4.1.4 Installation Issue Rate Topic   - - - - -

 
  • hiskif
  • Junior Member
  • Members
  • Join Date: 19-Feb 09
  • 4 posts

Posted 10 May 2014 - 06:40 PM #1

I am trying to install cs-cart 4.1.4 on a dedicated server but the installation does not start.
When I type the domain name it gives me the following message,

CS-Cart is not installed. Please click here to start the installation process: [install]

When I click on install it forwards me to www.domainname.com/install and gives the same message and
the following clicks on "install" forwards to www.domainname.com/install/install and this goes on. It keeps adding /install to the end and gives the same message.

Has anyone experienced such problem? Any suggestions?

 

Posted 10 May 2014 - 06:52 PM #2

I think it's a permissions problem. Do you have the permissions set correctly?

 
  • hiskif
  • Junior Member
  • Members
  • Join Date: 19-Feb 09
  • 4 posts

Posted 11 May 2014 - 12:53 AM #3

This is how it looks.

xendash [~/www]# chmod 666 config.local.php
xendash [~/www]# chmod -R 777 design images var
xendash [~/www]# find design -type f -print0 | xargs -0 chmod 666
xendash [~/www]# find images -type f -print0 | xargs -0 chmod 666
xendash [~/www]# find var -type f -print0 | xargs -0 chmod 666
xendash [~/www]# ls -lrt
total 66852

-rw-r--r-- 1 xendash xendash 1972 Apr 23 04:18 .htaccess
-rw-r--r-- 1 xendash xendash 15975 Apr 23 04:18 copyright.txt
-rw-r--r-- 1 xendash xendash 334073 Apr 23 04:18 changelog.txt
-rw-r--r-- 1 xendash xendash 1313 Apr 23 04:18 api.php
-rw-r--r-- 1 xendash xendash 1334 Apr 23 04:18 admin.php
-rw-r--r-- 1 xendash xendash 664 Apr 23 04:18 httpd.ini
-rw-r--r-- 1 xendash xendash 7092 Apr 23 04:18 install.html
-rw-r--r-- 1 xendash xendash 4282 Apr 23 04:18 init.php
-rw-r--r-- 1 xendash xendash 1292 Apr 23 04:18 index.php
drwxrwxrwx 7 xendash xendash 4096 Apr 23 04:18 images/
-rw-r--r-- 1 xendash xendash 16575 Apr 23 04:18 store_closed.html
-rw-r--r-- 1 xendash xendash 140 Apr 23 04:18 robots.txt
drwxr-xr-x 5 xendash xendash 4096 Apr 23 04:18 js/
drwxrwxr-x 6 xendash xendash 4096 Apr 23 04:19 install/
drwxrwxrwx 3 xendash xendash 4096 Apr 23 04:19 design/
-rw-r--r-- 1 xendash xendash 8082 Apr 23 04:19 config.php
-rw-rw-rw- 1 xendash xendash 4973 Apr 23 04:19 config.local.php
drwxr-xr-x 9 xendash xendash 4096 Apr 23 04:19 app/
drwxrwxrwx 6 xendash xendash 4096 Apr 23 04:21 var/
drwx--x--x 12 xendash xendash 4096 May 10 17:41 ../
-rw-r--r-- 1 xendash xendash 67987159 May 10 17:41 cscart_v4.1.4.tgz
drwxr-xr-x 8 xendash nobody 4096 May 10 17:43 ./


I just did untar the files and ran the commands in the installation guide for the permissions. It still does the same thing. Every click on "install" adds up /install to the URL and does nothing.

http://www.domain.com/install/install/install/install

I enabled "display errors" in the config file but no error message at all. PHP version is PHP 5.3.27, MySql version is 5.1.73-cll, Apache Server version: Apache/2.2.26.

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 21914 posts

Posted 12 May 2014 - 07:43 AM #4

This is how it looks.

xendash [~/www]# chmod 666 config.local.php
xendash [~/www]# chmod -R 777 design images var
xendash [~/www]# find design -type f -print0 | xargs -0 chmod 666
xendash [~/www]# find images -type f -print0 | xargs -0 chmod 666
xendash [~/www]# find var -type f -print0 | xargs -0 chmod 666
xendash [~/www]# ls -lrt
total 66852

-rw-r--r-- 1 xendash xendash 1972 Apr 23 04:18 .htaccess
-rw-r--r-- 1 xendash xendash 15975 Apr 23 04:18 copyright.txt
-rw-r--r-- 1 xendash xendash 334073 Apr 23 04:18 changelog.txt
-rw-r--r-- 1 xendash xendash 1313 Apr 23 04:18 api.php
-rw-r--r-- 1 xendash xendash 1334 Apr 23 04:18 admin.php
-rw-r--r-- 1 xendash xendash 664 Apr 23 04:18 httpd.ini
-rw-r--r-- 1 xendash xendash 7092 Apr 23 04:18 install.html
-rw-r--r-- 1 xendash xendash 4282 Apr 23 04:18 init.php
-rw-r--r-- 1 xendash xendash 1292 Apr 23 04:18 index.php
drwxrwxrwx 7 xendash xendash 4096 Apr 23 04:18 images/
-rw-r--r-- 1 xendash xendash 16575 Apr 23 04:18 store_closed.html
-rw-r--r-- 1 xendash xendash 140 Apr 23 04:18 robots.txt
drwxr-xr-x 5 xendash xendash 4096 Apr 23 04:18 js/
drwxrwxr-x 6 xendash xendash 4096 Apr 23 04:19 install/
drwxrwxrwx 3 xendash xendash 4096 Apr 23 04:19 design/
-rw-r--r-- 1 xendash xendash 8082 Apr 23 04:19 config.php
-rw-rw-rw- 1 xendash xendash 4973 Apr 23 04:19 config.local.php
drwxr-xr-x 9 xendash xendash 4096 Apr 23 04:19 app/
drwxrwxrwx 6 xendash xendash 4096 Apr 23 04:21 var/
drwx--x--x 12 xendash xendash 4096 May 10 17:41 ../
-rw-r--r-- 1 xendash xendash 67987159 May 10 17:41 cscart_v4.1.4.tgz
drwxr-xr-x 8 xendash nobody 4096 May 10 17:43 ./


I just did untar the files and ran the commands in the installation guide for the permissions. It still does the same thing. Every click on "install" adds up /install to the URL and does nothing.

http://www.domain.com/install/install/install/install

I enabled "display errors" in the config file but no error message at all. PHP version is PHP 5.3.27, MySql version is 5.1.73-cll, Apache Server version: Apache/2.2.26.


If you are ready to provide us with the temporary FTP access, please PM me. Thanks.
GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • mattias
  • Junior Member
  • Members
  • Join Date: 03-Nov 07
  • 2 posts

Posted 20 May 2014 - 10:35 AM #5

I am having the same issue. Did you ever figure it out?

 
  • mattias
  • Junior Member
  • Members
  • Join Date: 03-Nov 07
  • 2 posts

Posted 23 May 2014 - 10:34 PM #6

problem resolved in 4.1.5

 
  • novitas
  • Member
  • Members
  • Join Date: 11-Feb 11
  • 18 posts

Posted 27 May 2014 - 10:06 PM #7

Not resolved for me in 4.1.5. Strange thing is before it installed just fine (testing). But now after I deleted the files to start the installation from scratch, it does the install/ loop thing.

All the permissions are set correctly. The first time that it didn't work, I uncommented the url redirect line in the htaccess file, and it worked, but now, even that doesn't work.

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 21914 posts

Posted 28 May 2014 - 09:02 AM #8

Not resolved for me in 4.1.5. Strange thing is before it installed just fine (testing). But now after I deleted the files to start the installation from scratch, it does the install/ loop thing.

All the permissions are set correctly. The first time that it didn't work, I uncommented the url redirect line in the htaccess file, and it worked, but now, even that doesn't work.


If you are ready to provide us with the temporary FTP access, please PM me. Thanks.
GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • novitas
  • Member
  • Members
  • Join Date: 11-Feb 11
  • 18 posts

Posted 28 May 2014 - 04:13 PM #9

eComLabs. How about offering a solution if you have one instead.

 

Posted 28 May 2014 - 04:37 PM #10

eComLabs. How about offering a solution if you have one instead.


They probably don't until they start checking out what's happening on your server...which is why they are asking for temporary FTP access. You could also contact CS-Cart support via helpdesk.

 
  • novitas
  • Member
  • Members
  • Join Date: 11-Feb 11
  • 18 posts

Posted 28 May 2014 - 04:54 PM #11

Fixed the problem. Make sure the INSTALL directory has the 755 permissions.

 
  • eComLabs
  • CS-Cart Expert
  • Authorized Reseller
  • Join Date: 27-Jan 14
  • 21914 posts

Posted 29 May 2014 - 08:37 AM #12

They probably don't until they start checking out what's happening on your server...which is why they are asking for temporary FTP access. You could also contact CS-Cart support via helpdesk.


Correct, thank you. Different servers, different problems, different solutions. I am glad to hear that novitas solved the issue.
GET A FREE QUOTE | CS-Cart Add-ons | CS-Cart Licenses | CS-Cart Development | CS-Cart Design | Server Configuration | UniTheme and YOUPI
CS-Cart                USD 345     Multi-Vendor              USD 1250    Multi-Vendor PLUS           USD 3100 (2775)
CS-Cart Ultimate  USD 775     CS-Cart + YOUPI      USD 545      Multi-Vendor Ultimate       USD 7500 (6000)

 
  • BearBug
  • Junior Member
  • Members
  • Join Date: 20-Feb 08
  • 35 posts

Posted 02 June 2014 - 03:55 AM #13

Fixed the problem. Make sure the INSTALL directory has the 755 permissions.


This is the correct solution.
Thank you!